HDU 5119 Happy Matt Friends 递推

本文介绍了一种算法问题,即Matt和他的朋友们通过选择特定的玩家来赢得游戏的方法数量。问题中,每个朋友都有一个魔法数字,Matt的目标是选出一些朋友,使他们魔法数字的异或和大于等于指定值M以获胜。文章提供了完整的代码实现,并解释了一个示例案例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 3294    Accepted Submission(s): 1285


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6).

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input
  
  
2 3 2 1 2 3 3 3 1 2 3
 

Sample Output
  
  
Case #1: 4

Case #2: 2
Hint
In the first sample, Matt can win by selecting:friend with number 1 and friend with number 2. The xor sum is 3.friend with number 1 and friend with number 3. The xor sum is 2.friend with number 2. The xor sum is 2.friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

Source
 

Recommend
liuyiding

 

这个,先找到最大可能的数,然后的就因为年代久远不记得了...不过代码很短,应该很简单,看一看应该就差不多了


#include <bits/stdc++.h>

using namespace std;

int m,n,T,temp;
long long dp[1050000],dp1[1050000],ans;

int main()
{
    cin>>T;
    for(int k=1;k<=T;k++)
    {
        cin>>m>>n;
        memset(dp,0,sizeof(dp));
        memset(dp1,0,sizeof(dp1));
        dp[0]=dp1[0]=1;
        ans=0;
        for(int i=1;i<=m;i++)
        {
            cin>>temp;
            for(int j=0;j<=1048577;j++)
                if(dp[j])
                    dp1[j^temp]+=dp[j];
            for(int j=0;j<=1048577;j++)
                dp[j]=dp1[j];
        }
        for(int i=n;i<=1048577;i++)
            ans+=dp[i];
        cout<<"Case #"<<k<<": "<<ans<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值