算法学习_CCF_201312-1_出现次数最多的数

试题编号: 201312-1
试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:
问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10

第一次提交得分50分代码

 #include <iostream>
 #include <algorithm>
 using namespace std;
 int main(){
 	int n;
 	cin>>n;
 	int *s=new int[6];
 	int temp;
 	for(int i=0;i<6;i++){
 		cin>>temp;
 		s[i]=temp;
	 }
 	
 	sort(s,s+n);
 	
	int i=0;
	int result=s[i];
	int num=0;
	int temp1=s[i];
	temp=1;
 	while(i<6){
 		temp1=s[i];
 		if(s[i]==s[++i]){
 			temp++;
		}
		else{
			if(temp>num){
				num=temp;
				result=temp1;
			}
			else{
				temp=1;
			}
		}
	 }
 	cout<<result;
 	return 0;
 }

第二次使用了map统计次数100分代码

#include<iostream>
#include<map>
using namespace std;
int main(){
	int n;
	int a;
    map<int ,int>m;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
    	scanf("%d",&a);
    	m[a]++;
	}
    int max=0;
	int max_num=0;
	for(map<int,int>::iterator it=m.begin();it!=m.end();it++){
		if(it->second>max_num){
			max=it->first;
			max_num=it->second;
		}
	}
	printf("%d",max);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值