大数相加

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int N=1E3+7;
char arr1[N];
char arr2[N];
int  sum[N];
int main(){
    int t,k1=0;
    cin>>t;
    while(t--){
    
    
        k1++;
        memset(sum,0,sizeof(sum));
        scanf("%s",arr1);
        scanf("%s",arr2); 
        
        int len1=strlen(arr1);
        int len2=strlen(arr2);
        int k=0;
        int i,j;
        
        
        for(i=len1-1,j=len2-1;i>=0&&j>=0;i--,j--){
            int y=arr1[i]-'0'+arr2[j]-'0';
            if(y+sum[k]>=10){//注意这里是y+sum[k]判断是否 进位 
                sum[k+1]++;//进位的话就在 k+1 位置上累加一次 
                sum[k]+=y-10;
            }
            else {
                sum[k]+=y;
            }
            k++;
        }
        
        
        if(k<len1){
            for(int x=i;x>=0;x--){
                sum[k]+=arr1[x]-'0';
                k++;
            }
        }        
        else if(k<len2){
            for(int x=j;x>=0;x--){
                sum[k]+=arr2[x]-'0';
                k++;
            }
        }        
        else if(sum[k]!=0){//k这个位置可能会有残余 
            k++;
        }
        
        
        
        printf("Case %d:\n",k1);
        printf("%s + %s = ",arr1,arr2);
        for(int i=k-1;i>=0;i--)
            printf("%d",sum[i]); 
        cout<<endl;
        if(t>=1) cout<<endl;
        
        
        
    }
    
    return 0;
}

 

转载于:https://www.cnblogs.com/Accepting/p/11377569.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值