【线段树】单点更新 hdu 5475 An easy problem

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2322    Accepted Submission(s): 940
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
Source

题意:其实X=1,输入n,m ;n行数据,m是模;每行数据输入两个操作,1,x和2,y;意义分别为乘以x、除以第y行数据所对应的x(题目保证第y行为1操作 )输出每行数据计算后的结果X;
思路:因为题意没有确定m而且m不确定为素数,所以我们不能用逆元来求;利用线段树单点更新(将某个点更新为1),区间(1~n)求积;
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

typedef long long LL;
const int N=100005;

int n,M;

struct NODE
{
    int l,r;
    LL value;
    int mid(){
        return (l+r)>>1;
    }
}tree[N<<2];

void BuildTree(int l,int r,int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    tree[rt].value=1;
    if(l==r)
    {
        tree[rt].value=1;
        return ;
    }

    int m=tree[rt].mid();
    BuildTree(l,m,rt<<1);
    BuildTree(m+1,r,rt<<1|1);
    tree[rt].value=tree[rt<<1].value*tree[rt<<1|1].value%M;
}

void UpdateTree(int l,LL val,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==l)
    {
        tree[rt].value=val;
        return ;
    }
    int m=tree[rt].mid();
    if(l<=m) UpdateTree(l,val,rt<<1);
    if(l>m) UpdateTree(l,val,rt<<1|1);
    tree[rt].value=tree[rt<<1].value*tree[rt<<1|1].value%M;
}

LL Query(int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
        return tree[rt].value;

    int m=tree[rt].mid();
    if(r<=m) return Query(l,r,rt<<1);
    else if(l>m) return Query(l,r,rt<<1|1);
    else return (Query(l,m,rt<<1)*Query(m+1,r,rt<<1|1))%M;
}

int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        scanf("%d%d",&n,&M);
        BuildTree(1,n,1);
        printf("Case #%d:\n",++cas);
        for(int i=1;i<=n;i++)
        {
            int a;
            LL b;
            scanf("%d%I64d",&a,&b);

            if(a==1)
                UpdateTree(i,b,1);
            else if(a==2)
                UpdateTree(b,1,1);

            printf("%I64d\n",tree[1].value);
        }
    }
    return 0;
}


 
FFmpeg是一款功能强大的开源多媒体处理工具,广泛应用于视频和音频的编码、解码、转换以及流媒体处理。然而,由于历史原因和标准限制,原生的FFmpeg并不支持将H.265(高效视频编码)格式的视频流封装到FLV(Flash Video)容器中。FLV是一种常见的网络流媒体传输格式,但其最初设计时并未考虑现代高效的H.265编码标准。因此,当尝试将H.265编码的视频与FLV容器结合时,会出现“Video codec hevc not compatible with flv”的错误提示,表明FFmpeg无法识别这种组合。 为了解决这一问题,开发者通常需要对FFmpeg的源代码进行修改和扩展。一个名为“用于解决ffmpeg不支持flv+h265需要修改的文件.zip”的压缩包中包含了一些源代码文件,这些文件旨在扩展FFmpeg的功能,使其能够处理FLV容器中的H.265编码内容。压缩包中的三个关键文件分别是“flvdec.c”“flvenc.c”和“flv.h”,它们分别对应FLV的解码器、编码器和头文件。 flvdec.c:这是FFmpeg的FLV解码器源代码,经过修改后可能支持读取和解析包含H.265数据的FLV流。解码器的作用是从FLV容器中提取视频数据,并将其转换为可处理的原始像素格式。 flvenc.c:这个文件包含FLV编码器的源代码,经过调整后可能允许将H.265编码的视频流封装到FLV容器中。编码器负责将原始视频数据编码为H.265格式,并将其打包到FLV文件中。 flv.h:这是一个头文件,定义了FLV格式相关的常量、结构体和函数原型。修改该文件可能涉及添加或更新与H.265支持相关的定义和接口。 要应用这些修改,开发者需要重新编译FFmpeg源代码,并将修改后的版本替换原有的FFmpeg安装。这样,用户就可以使用定制版的FFmpeg来处理FLV+H.265的
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值