1032 The 3n + 1 problem

The 3n + 1 problem


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 

Sample Input
  
  
1 10 100 200 201 210 900 1000
 

Sample Output
  
  
1 10 20 100 200 125 201 210 89 900 1000 174
 

最初用蛮力算法,效率是N的平方。输入 1 to 1,000,000就开始慢慢算了。
然后就想是不是要大数处理呢,还是又一个规律循环?或者就像之前的卡特兰数,另外有什么高效的算法。
另外没注意区间,sample中误导i小于j,没有多想。(sample input里面我看了几遍,虽然没说必定i<j,但也没看出哪里说i可以小于j。定向思维了还是英语不照啊?哪位童鞋可以留言说下啊?)
由于比较简单,最初没用函数,写一疙瘩里,自己测试没问题,但OJ老是wrong answer。想来可能是哪个变量没重置。但变量太多,晕掉了。直接提取到函数中,就AC了…
函数真是好东东,用起来多多益善啊(~ o ~)~zZ

/*
 *	hdu 1032 The 3n + 1 problem
 *	2011/07/25
 *	artwalk
 */

#include <iostream>

using namespace std;

int MAX(int i, int j);
int count(int k);

int main(int ac, char** av)
{
	int i, j;
	
	while ( cin >> i >> j ) {
		cout << i << " " << j << " ";

		if ( i > j ) {	// 注意 i j 之间
			int temp = i;
			i = j;
			j = temp;
		}
	
		cout << MAX(i, j) << endl;
			
	}

	return 0;
}

int MAX(int i, int j) {
	// i to j 中最大次数
	int maxnum = 0;
	
	for ( ; i <=j; ++i ) {
		int k = i;
		int temp = 0;
	
		temp = count(k);
		if ( maxnum < temp) {
			maxnum = temp;
		}
	}
	return maxnum;
}

int count(int k) {
	// 单个数的次数
	int num = 1;
	while ( k != 1 ) {
		if ( k % 2 != 0 ) {
			k = 3 * k + 1;
		} else {
			k = k >> 1;
		}
		++num;
	}

	return num;
}


内容概要:本文详细介绍了基于FPGA的144输出通道可切换电压源系统的设计与实现,涵盖系统总体架构、FPGA硬件设计、上位机软件设计以及系统集成方案。系统由上位机控制软件(PC端)、FPGA控制核心和高压输出模块(144通道)三部分组成。FPGA硬件设计部分详细描述了Verilog代码实现,包括PWM生成模块、UART通信模块和温度监控模块。硬件设计说明中提及了FPGA选型、PWM生成方式、通信接口、高压输出模块和保护电路的设计要点。上位机软件采用Python编写,实现了设备连接、命令发送、序列控制等功能,并提供了一个图形用户界面(GUI)用于方便的操作和配置。 适合人群:具备一定硬件设计和编程基础的电子工程师、FPGA开发者及科研人员。 使用场景及目标:①适用于需要精确控制多通道电压输出的实验环境或工业应用场景;②帮助用户理解和掌握FPGA在复杂控制系统中的应用,包括PWM控制、UART通信及多通道信号处理;③为研究人员提供一个可扩展的平台,用于测试和验证不同的电压源控制算法和策略。 阅读建议:由于涉及硬件和软件两方面的内容,建议读者先熟悉FPGA基础知识和Verilog语言,同时具备一定的Python编程经验。在阅读过程中,应结合硬件电路图和代码注释,逐步理解系统的各个组成部分及其相互关系。此外,实际动手搭建和调试该系统将有助于加深对整个设计的理解。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值