<?xml version="1.0" encoding="utf-8" ?><rss version="2.0"><channel><title><![CDATA[admin_long的博客]]></title><description><![CDATA[]]></description><link>https://blog.youkuaiyun.com/admin_long</link><language>zh-cn</language><generator>https://blog.youkuaiyun.com/</generator><copyright><![CDATA[Copyright &copy; admin_long]]></copyright><item><title><![CDATA[QQ实现第三方登陆]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51685113</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51685113</guid><author>admin_long</author><pubDate>Wed, 15 Jun 2016 20:27:58 +0800</pubDate><description><![CDATA[一、准备工作
接入QQ登录前，网站需首先进行申请，获得对应的appid与appkey，以保证后续流程中可正确对网站与用户进行验证与授权。
申请appid和appkey的用途
 appid ：应用的唯一标识。在OAuth2.0认证过程中，appid的值即为oauth_consumer_key的值。

appkey：appid对应的密钥，访问用户资源时用来验证应用的合法性。在OAuth2.0]]></description><category></category></item><item><title><![CDATA[Linux常用20个命令]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51668435</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51668435</guid><author>admin_long</author><pubDate>Tue, 14 Jun 2016 07:37:27 +0800</pubDate><description><![CDATA[1、cd命令
这是一个非常基本，也是大家经常需要使用的命令，它用于切换当前目录，它的参数是要切换到的目录的路径，可以是绝对路径，也可以是相对路径。如：


[plain] 
view plain 
copy 
print?


cd /root/Docements # 切换到目录/root/Docements  cd ./path          # 切换到当前目录下的pat]]></description><category></category></item><item><title><![CDATA[FIFO 、LRU、LFU三种算法]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51635844</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51635844</guid><author>admin_long</author><pubDate>Sat, 11 Jun 2016 11:21:32 +0800</pubDate><description><![CDATA[提到缓存，有两点是必须要考虑的：
（1）缓存数据和目标数据的一致性问题。
（2）缓存的过期策略（机制）。
     其中，缓存的过期策略涉及淘汰算法。常用的淘汰算法有下面几种：
（1）FIFO：FirstIn First Out，先进先出
（2）LRU：LeastRecently Used，最近最少使用
（3）LFU：LeastFrequently Used，最不经常使用
     ]]></description><category></category></item><item><title><![CDATA[sessionID与cookie]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51635818</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51635818</guid><author>admin_long</author><pubDate>Sat, 11 Jun 2016 11:14:54 +0800</pubDate><description><![CDATA[一、cookie机制和session机制的区别
*************************************************************************************
具体来说cookie机制采用的是在客户端保持状态的方案，而session机制采用的是在服务器端保持状态的方案。
同时我们也看到，由于才服务器端保持状态的方案在客户端也需要保存]]></description><category></category></item><item><title><![CDATA[TCP/IP协议栈的基本工作原理]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51601147</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51601147</guid><author>admin_long</author><pubDate>Tue, 07 Jun 2016 07:25:20 +0800</pubDate><description><![CDATA[TCP/IP是互联网的核心协议，也是大多数网络应用的核心协议。就前面一段时间面试中问到的TCP/IP问题，这里给出一个简单的小结。
 
TCP由RFC793、RFC1122、RFC1323、RFC2001、RFC2018以及RFC2581定义。
 
(1) TCP概述
a. TCP提供的是面向连接的全双工服务。
TCP所有的数据会匹配到由源地址，目的地址，源端口，目的端口构成的一个TC]]></description><category></category></item><item><title><![CDATA[网络七层协议]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51601142</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51601142</guid><author>admin_long</author><pubDate>Tue, 07 Jun 2016 07:15:50 +0800</pubDate><description><![CDATA[网络七层协议
编辑

OSI是一个开放性的通信系统互连参考模型，他是一个定义的非常好的协议规范。OSI模型有7层结构，每层都可以有几个子层。 OSI的7层从上到下分别是 7

应用层 6 
表示层 5 会话层 4 
传输层 3 网络层 2 
数据链路层 1 
物理层 其中高层，即7、6、5、4层定义了应用程序的功能，下面3层，即3、2、1层主要面向通过网络的端到端的数据流。]]></description><category></category></item><item><title><![CDATA[对于大流量的网站，采用什么样的方法来解决访问量问题]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51576267</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51576267</guid><author>admin_long</author><pubDate>Fri, 03 Jun 2016 08:57:47 +0800</pubDate><description><![CDATA[常见的方法, 采用CDN分流,  或者升级服务器配置.
另外, 网站如果ss没有开启网页压缩功能, 也可以在服务器上开启此功能, 也能大量减少流量.]]></description><category></category></item><item><title><![CDATA[Sphinx全文索引搜索常见的一些错误处理收集]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51557108</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51557108</guid><author>admin_long</author><pubDate>Wed, 01 Jun 2016 16:36:40 +0800</pubDate><description><![CDATA[sphinx无法启动的解决
索引或者查询时提示：ERROR: invalid token in 配置文件 line 1 col 1.：

该提示表示当前的配置文件的编码不是UTF-8（无BOM头）格式，无法正确解析，请使用编辑软件打开配置文件，另存为UTF-8（无BOM头）格式；

错误的编码格式包括：Unicode、Unicode BOM、Unicode big endian、Unic]]></description><category></category></item><item><title><![CDATA[PHP5权限控制修饰符]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51549090</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51549090</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 21:01:43 +0800</pubDate><description><![CDATA[方法/属性
类内
类外
子类


public(公共)





private（私有成员）





protected（保护成员）]]></description><category></category></item><item><title><![CDATA[php联系题]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51549068</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51549068</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 20:58:53 +0800</pubDate><description><![CDATA[练习题一
　　1. echo count(“abc”); 输出什么?
　　答案:1
　　2. 用PHP代码写出显示客户端IP与服务器IP的代码。
　　答案：客户端 getenv(‘REMOTE_ADDR’); 服务器端 getenv(‘SERVER_ADDR’);
　　// gethostbyname(“www.phpmst.com”);
　　3. error_reporting(20]]></description><category></category></item><item><title><![CDATA[能够使HTML和PHP分离开使用的模板]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51548809</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51548809</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 20:24:18 +0800</pubDate><description><![CDATA[有Smarty, Dwoo, tinyButStrong Templete Lite Savant, phemplate XTemplate]]></description><category></category></item><item><title><![CDATA[echo(),print(),print_r()的区别]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51548682</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51548682</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 20:09:33 +0800</pubDate><description><![CDATA[echo()
可以一次输出多个值，多个值之间用逗号分隔。echo是语言结构(language construct)，而并不是真正的函数，因此不能作为表达式的一部分使用。
print()
函数print()打印一个值（它的参数），如果字符串成功显示则返回true，否则返回false。
print_r()
可以把字符串和数字简单地打印出来，而数组则以括起来的键和值得列表形式显示，并以Arra]]></description><category></category></item><item><title><![CDATA[数据库中的事务是什么]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51548655</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51548655</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 20:07:25 +0800</pubDate><description><![CDATA[事务是作为一个逻辑单元执行的一系列操作，一个逻辑工作单元必须有四个属性，称为 ACID（原子性、一致性、隔离性和持久性）属性，
    只有这样才能成为一个事务：
原子性
事务必须是原子工作单元；对于其数据修改，要么全都执行，要么全都不执行。

一致性
事务在完成时，必须使所有的数据都保持一致状态。在相关数据库中，所有规则都必须应用于事务的修改，以保持所有数据的完整性。
    事务结束时，所有的]]></description><category></category></item><item><title><![CDATA[SESSION 与COOKIE的区别]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51548634</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51548634</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 20:04:08 +0800</pubDate><description><![CDATA[1、session保存在服务器，客户端不知道其中的信息；cookie保存在客户端，服务器能够知道其中的信息。   
    
  2、session中保存的是对象，cookie中保存的是字符串。   
    
  3、session不能区分路径，同一个用户在访问一个网站期间，所有的session在任何一个地方都可以访问到。而cookie中如果设置了路径参数，那么同一个网站中不同路径下的c]]></description><category></category></item><item><title><![CDATA[表单中 get与post提交方法的区别]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51548593</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51548593</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 19:58:34 +0800</pubDate><description><![CDATA[表单提交中get和post方式的区别有5点 
1.get是从服务器上获取数据，post是向服务器传送数据。 
2.get是把参数数据队列加到提交表单的ACTION属性所指的URL中，值和表单内各个字段一一对应，在URL中可以看到。post是通过HTTPpost机制，将表单内各个字段与其内容放置在HTML HEADER内一起传送到ACTION属性所指的URL地址。用户看不到这个过程。 
3.对]]></description><category></category></item><item><title><![CDATA[Git命令行介绍和使用说明]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51542773</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51542773</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 08:05:26 +0800</pubDate><description><![CDATA[命令“git”或者“git help”查询常用命令

 
【add】：
“git add”——不但是用来添加不在版本控制中的新文件，也用于添加已在版本控制中但是刚修改过的文件; 在这两种情况下,
 Git都会获得当前文件的快照并且把内容暂存(stage)到索引中，为下一次commit做好准备。Git跟踪的是内容不是文件。
【bisect】
【branch】：
“git branch]]></description><category></category></item><item><title><![CDATA[Git:代码冲突常见解决方法]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51542769</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51542769</guid><author>admin_long</author><pubDate>Tue, 31 May 2016 07:59:13 +0800</pubDate><description><![CDATA[如果系统中有一些配置文件在服务器上做了配置修改,然后后续开发又新添加一些配置项的时候,

在发布这个配置文件的时候,会发生代码冲突:

error: Your local changes to the following files would be overwritten by merge:
        protected/config/main.php
Please, comm]]></description><category></category></item><item><title><![CDATA[Cookie/Session机制详解]]></title><link>https://blog.youkuaiyun.com/admin_long/article/details/51533473</link><guid>https://blog.youkuaiyun.com/admin_long/article/details/51533473</guid><author>admin_long</author><pubDate>Sun, 29 May 2016 19:33:49 +0800</pubDate><description><![CDATA[会话（Session）跟踪是Web程序中常用的技术，用来跟踪用户的整个会话。常用的会话跟踪技术是Cookie与Session。Cookie通过在客户端记录信息确定用户身份，Session通过在服务器端记录信息确定用户身份。
本章将系统地讲述Cookie与Session机制，并比较说明什么时候不能用Cookie，什么时候不能用Session。


1.1  Cookie机制
在程序中，会话]]></description><category></category></item></channel></rss>