hdu 5832 A water problem(简单数论)

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 291    Accepted Submission(s): 161


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

Input
There are several test cases(about  5  huge test cases).

For each test, we have a line with an only integer  N(0N) , the length of  N  is up to  10000000 .
 

Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

Sample Input
  
  
10001 0 333
 

Sample Output
  
  
Case #1: YES Case #2: YES Case #3: NO
 

Author
UESTC
 

Source
题意:有两个周期,求n%两个数是不是相等,相等输出YES,否则NO

思路:虽然本人是蒟蒻,不过此题抢到了一血还是挺开心的= = 

后面惨不忍睹了。最后A了四个题学校水平不行也晋级不了,可惜。

只要对每一位都取模即可,具体可以看代码。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 10000050
char a[N];
int main()
{
    int n=1;
    while(~scanf("%s",&a))
    {
        int len=strlen(a);
        int now=0,now1=0;
        for(int i=0;i<len;i++)
        {
            now=(now*10+a[i]-'0')%73;
            now1=(now1*10+a[i]-'0')%137;
        }
        if(now==now1) printf("Case #%d: YES\n",n++);
        else printf("Case #%d: NO\n",n++);
    }
    return 0;
}






HDU 2034 是一道经典的 A-B Problem 题目,通常涉及简单的数学运算或者字符串处理逻辑。以下是对此类问题的分析以及可能的解决方法。 ### HDU 2034 的题目概述 该题目要求计算两个数之间的差值 \(A - B\) 并输出结果。需要注意的是,输入数据可能存在多种情况,因此程序需要能够适应不同的边界条件和特殊情况[^1]。 #### 输入描述 - 多组测试数据。 - 每组测试数据包含两行,分别表示整数 \(A\) 和 \(B\)。 #### 输出描述 对于每组测试数据,输出一行表示 \(A - B\) 的结果。 --- ### 解决方案 此类问题的核心在于正确读取多组输入并执行减法操作。以下是实现此功能的一种常见方式: ```python while True: try: a = int(input()) b = int(input()) print(a - b) except EOFError: break ``` 上述代码片段通过循环不断接收输入直到遇到文件结束符 (EOF),适用于批量处理多组测试数据的情况。 --- ### 特殊考虑事项 尽管基本思路简单明了,在实际编码过程中仍需注意以下几点: 1. **大数值支持**:如果题目中的 \(A\) 或 \(B\) 可能非常大,则应选用可以容纳高精度的数据类型来存储这些变量。 2. **负数处理**:当 \(B>A\) 导致结果为负时,确保程序不会因符号错误而失效。 3. **异常捕获**:为了防止运行期间由于非法字符或其他意外状况引发崩溃,建议加入必要的错误检测机制。 --- ### 示例解释 假设给定如下样例输入: ``` 5 3 7 2 ``` 按照以上算法流程依次完成各步操作后得到的结果应当分别为 `2` 和 `5`。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值