hdu 2222 Keywords Search(AC自动机模板)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 51186    Accepted Submission(s): 16482


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
题意:给n个小串,再给一个大串,问大串里有多少个小串(一个小串只能计算一次)

思路:AC自动机模板题,这里的代码可以当做模板。

关于AC自动机可以看:点击打开链接

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 10050
#define M 1000050
char s[N],str[M];
struct Node
{
    struct Node *next[26];///儿子
    struct Node *fail;///失败指针
    int num;///以当前节点为最后一个字符的字符串的个数
    void init()
    {
        for(int i=0;i<26;i++)
            next[i]=NULL;
        fail=NULL;
        num=0;
    }
}*root;
void Insert()
{
    int len=strlen(s);
    Node *p=root;
    for(int i=0;i<len;i++)
    {
        int pos=s[i]-'a';
        if(p->next[pos]==NULL)
        {
            p->next[pos]=new Node;
            p->next[pos]->init();
        }
        p=p->next[pos];
    }
    p->num++;
}
void getfail()
{
    Node *p=root,*son;
    queue<Node *>que;
    que.push(p);
    while(!que.empty())
    {
        Node *now=que.front();
        que.pop();
        for(int i=0;i<26;i++)
        {
            son=now->next[i];
            if(son!=NULL)
            {
                if(now==root) now->next[i]->fail=root;
                else
                {
                    p=now->fail;
                    while(p)
                    {
                        if(p->next[i])
                        {
                            son->fail=p->next[i];
                            break;
                        }
                        p=p->fail;
                    }
                    if(!p) son->fail=root;
                }
                que.push(son);
            }
        }
    }
}
void query()
{
    Node *p=root,*temp;
    int cnt=0,len=strlen(str);
    for(int i=0;i<len;i++)
    {
        int pos=str[i]-'a';
        while(!p->next[pos]&&p!=root) p=p->fail;
        p=p->next[pos];
        if(!p) p=root;
        temp=p;
        while(temp!=root)
        {
            if(temp->num>0)
            {
                cnt+=temp->num;
                temp->num=-1;
            }
            else break;
            temp=temp->fail;
        }
    }
    printf("%d\n",cnt);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        root=new Node;
        root->init();
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s",s);
            Insert();
        }
        getfail();
        scanf("%s",str);
        query();
    }
    return 0;
}





内容概要:本文详细介绍了CCF-GESP认证的学习资源与知识点指南,分为官方资源与平台、知识点学习与解析、备考策略与工具、实战项目与进阶资源以及学习工具推荐五个部分。官方资源包括CCF数字图书馆提供的免费真题库、一站式学习平台和GESP官网的最新真题下载及考试环境说明。知识点学习部分涵盖Python、C++和图形化编程(Scratch)的核心内容与实战案例。备考策略方面,提出了基础、强化和冲刺三个阶段的分阶段计划,并强调了在线题库模拟测试与社区交流的重要性。实战项目与进阶资源则为不同编程语言提供了具体的应用场景,如Python的智能客服机器人和C++的并行编程与嵌入式开发。最后,推荐了多种学习工具,如代码编辑器VS Code、模拟考试平台和社区支持渠道。 适合人群:准备参加CCF-GESP认证考试的考生,特别是对Python、C++或Scratch编程语言有兴趣的学习者。 使用场景及目标:①帮助考生系统化地学习官方资源,熟悉考试形式和内容;②通过分阶段的备考策略,提高应试能力和编程技能;③利用实战项目和进阶资源,增强实际编程经验和解决复杂问题的能力。 阅读建议:建议考生按照文章中的分阶段备考策略逐步推进学习进度,充分利用官方提供的资源进行练习和模拟测试,并积极参与社区交流以获取更多备考经验和疑难解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值