POJ——3061Subsequence(尺取法)

解决一个经典的编程问题:寻找连续子序列最小长度使得其和大于等于给定目标值。使用滑动窗口法实现高效求解。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Subsequence
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11048 Accepted: 4571

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

尺取法入门题目,对于我这个大菜鸟有很大帮助啊

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
int main (void)
{
	int n,i,j,t,l,r,goal,minm;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%d%d",&n,&goal);
		int *list=new int[n+1];
		for (i=1; i<=n; i++)
		{
			scanf("%d",&list[i]);
		}
		l=r=1;
		minm=100000009;
		int temp=0;
		while (1)
		{
			while (r<=n&&temp<goal)
			{
				temp+=list[r++];
			}
			if(temp<goal)
				break;
			minm=min(r-l,minm);
			temp-=list[l++];
		}
		if(minm==100000009)
			printf("0\n");
		else	
			printf("%d\n",minm);
		delete []list;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值