月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。
输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。
输入样例:3 20 18 15 10 75 72 45输出样例:
94.50
这里很重要的一点 题目只说月饼的种类和需求是正整数 但是库存和价格没要求 因此应该设置double类型 int型有一组不通过
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<iterator>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdlib>
#include<iomanip>
using namespace std;
struct yuebing{
double w; //库存
double v; //总价格
double sign; //零售价
};
//以零售价排序 准备贪心
bool cmp( yuebing a , yuebing b ){
return a.sign > b.sign;
}
int main()
{
int N,D;
cin >> N >> D;
yuebing* a = new yuebing[N];
for( int i = 0 ; i < N ; i ++ )
cin >> a[i].w;
for( int i = 0 ; i < N ; i ++ ){
cin >> a[i].v;
a[i].sign = a[i].v/a[i].w; //计算出每种物品的零售价
}
sort(a,a+N,cmp);
int index = 0;
double res = 0;
int sum = 1;
int count = 1;
//while( sum <= D ){
// res += a[index].sign;
// count ++;
// sum ++;
// if( count > a[index].w ){
// index ++;
// count = 1;
// }
//}
for( int i = 0 ; i < N ; i ++ ){
if( D == 0 )
break;
if( D > a[i].w ){
D -= a[i].w;
res += a[i].v;
}
else{
res += D*a[i].sign*1.0;
D = 0;
}
}
//保留2位小数输出
cout << setiosflags(ios::fixed) << setprecision(2) << res << endl;
}