Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.
Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
The last test case is followed by a line containing two zeros, which means the end of the input.
Output
Output the sum of the value of the edges of the maximum pesudoforest.
Sample Input
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
Sample Output
3 5
AC代码。。。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 10008
int father[maxn];
int rank1[maxn];
bool r[maxn];//判断有没有环
int n,m;
int sumlen;
inline int max(int a,int b)
{
return a>b?a:b;
}
struct Edge
{
int from,to,len;
}edge[100008];
void init()
{
for(int i=0;i<=n;i++)
{
father[i]=i;
}
}
int find(int x)
{
if(x==father[x])return x;
return father[x]=find(father[x]);
}
void Union(int a,int b,int c)
{
int aa=find(a);
int bb=find(b);
if(aa==bb)
{
if(!r[aa])
{
r[aa]=1;
sumlen+=c;
}
return;
}
if(r[aa]&&r[bb])return;
if(r[aa]&&!r[bb])
{
father[bb]=aa;
}
else
{
father[aa]=bb;
}
sumlen+=c;
}
bool cmp(Edge a,Edge b)
{
return a.len>b.len;
}
int main()
{
while(scanf("%d%d",&n,&m)==2&&(n||m))
{
init();
sumlen=0;
memset(rank1,0,sizeof(rank1));
memset(r,0,sizeof(r));
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].len);
}
sort(edge+1,edge+1+m,cmp);
for(int i=1;i<=m;i++)
{
Union(edge[i].from,edge[i].to,edge[i].len);
}
printf("%d\n",sumlen);
}
return 0;
}
WA代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 10008
int father[maxn];
int rank1[maxn];
bool r[maxn];//判断有没有环
int n,m;
int sumlen;
inline int max(int a,int b)
{
return a>b?a:b;
}
struct Edge
{
int from,to,len;
}edge[100008];
void init()
{
for(int i=0;i<=n;i++)
{
father[i]=i;
}
}
int find(int x)
{
if(x==father[x])return x;
return father[x]=find(father[x]);
}
void Union(int a,int b,int c)
{
int aa=find(a);
int bb=find(b);
if(r[aa]&&r[bb])return;///如果已经有2个环了
//一个有环但是不同祖宗可以连
if((r[aa]||r[bb])&&aa!=bb)
{
father[bb]=aa;
if(!r[aa])r[aa]=1;
rank1[aa]+=rank1[bb]+c;
}
//无环能连
if(!(r[aa]||r[bb]))
{
father[bb]=aa;
if(aa==bb)//如果祖宗相同,那就会出现
{
r[aa]=1;
rank1[aa]+=c;
}
else rank1[aa]+=rank1[bb]+c;
}
sumlen=max(sumlen,rank1[aa]);
}
bool cmp(Edge a,Edge b)
{
return a.len>b.len;
}
int main()
{
while(scanf("%d%d",&n,&m)==2&&(n||m))
{
init();
sumlen=0;
memset(rank1,0,sizeof(rank1));
memset(r,0,sizeof(r));
for(int i=1;i<=m;i++)
{
scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].len);
}
sort(edge+1,edge+1+m,cmp);
for(int i=1;i<=m;i++)
{
Union(edge[i].from,edge[i].to,edge[i].len);
}
printf("%d\n",sumlen);
}
return 0;
}