hdu 5224 Tom and Paper

Description

There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
 

Input

In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.  
 

Output

For each case, output a integer, indicates the answer.
 

Sample Input

    
    
3 2 7 12
 

Sample Output

    
    
6 16 14
 
题意:
输入一张矩形纸的面积,求出其最小周长。
思路:
直接暴力求解,如果用两重循环,会超时,换成一重循环则不会。
代码:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    int n;
    double x;
    int y;
    scanf("%d",&T);
    while(T--)
    {
        int   ans=2*1000000000;
        scanf("%d",&n);
        x=sqrt(n);
        for(int i=1;i<=x;i++)
        {
           if(n%i==0)
           {
               y=n/i;
               ans=min(ans,2*(i+y));
           }

        }

         printf("%d\n",ans);



    }
    return 0 ;
}

 
 
 
 
 
 
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值