Description
There is a piece of paper in front of Tom, its length and width are integer. Tom knows the area of this paper, he wants to know the minimum perimeter of this paper.
Input
In the first line, there is an integer T indicates the number of test cases. In the next T lines, there is only one integer n in every line, indicates the area of paper.



















Output
For each case, output a integer, indicates the answer.
Sample Input
3 2 7 12
Sample Output
6 16 14
题意:
输入一张矩形纸的面积,求出其最小周长。
思路:
直接暴力求解,如果用两重循环,会超时,换成一重循环则不会。
代码:
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
int T;
int n;
double x;
int y;
scanf("%d",&T);
while(T--)
{
int ans=2*1000000000;
scanf("%d",&n);
x=sqrt(n);
for(int i=1;i<=x;i++)
{
if(n%i==0)
{
y=n/i;
ans=min(ans,2*(i+y));
}
}
printf("%d\n",ans);
}
return 0 ;
}