1054 求平均值(20 分)
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number
,其中 X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中 K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined
替换 Y
。如果 K
为 1,则输出 The average of 1 number is Y
。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
如果知道这些,做此题会更加容易点:
- stof是string库中能将字符串转化为浮点数的方法。
- find,是string的查找方法,返回第一个待查元素的地址。
- count,计数,可以统计某个元素的数量。
#include <iostream>
#include <algorithm>
#include <string>
#include <cstdio>
#include <math.h>
using namespace std;
bool islegal(string s)
{
int len=s.length();
int cnt=0;
for(int i=0;i<len;i++)
{
if(s[i]=='.')
cnt++;
}
if(cnt>=2)return false;
else if(cnt==1)
{
for(int i=0;i<len;i++)
{ if(isdigit(s[i])==false&&s[i]!='.'&&s[0]!='-')
{
return false;
}
if(len-s.find('.')-1>2)
{
return false;
}
}
if(abs(stof(s))>1000)
return false;
}
else
{ for(int i=0;i<len;i++)
{ if(isdigit(s[i])==false)
{
return false;
}
}
if(abs(stof(s))>1000)
return false;
}
return true;
}
int main()
{ int n;
cin>>n;
int num=0;
double sum=0;
for(int i=0;i<n;i++)
{
string s;
cin>>s;
if(islegal(s)==false)
{
printf("ERROR: ");
cout<<s<<" ";
printf("is not a legal number\n");
}
else
{ sum+=stof(s);
num++;
}
}
if(num==1)
{ cout<<"The average of "<<num<<" number is ";
}
else
{
cout<<"The average of "<<num<<" numbers is ";
}
if(num!=0)
{
printf("%.2f",sum/num);
}
else
{
cout<<"Undefined";
}
return 0;
}