Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
public class Main {
public static void main(String[] args) {
Scanner n1 = new Scanner(System.in);
int result = 0;
// Scanner n2= new Scanner(System.in);
while (n1.hasNextInt()) {
int n = n1.nextInt();
for (int i = 1; i <= n; i++) {
result = result + i;
}
System.out.println(result);
System.out.println();//换行
result = 0;
}
}
}