WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!......
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009
Hint : 0! = 1, N! = N*(N-1)!
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4 5Sample Output
24 120
题目大意:求n的阶乘,对2009取余。
思路:2009=7*7*41;
所以当n>=41的时候结果都为0;
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
ll n;
while(~scanf("%lld",&n))
{
if(n==0)
printf("1\n");
else if(n>=41)
printf("0\n");
else
{
ll ans=1;
for(ll i=2; i<=n; i++)
ans=ans*i%2009;
printf("%lld\n",ans%2009);
}
}
return 0;
}