hdu 1159 Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15480    Accepted Submission(s): 6445


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.  
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.  
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 
•求两个string的最大公共字串,动态规划的经典问题。算法导论有详细的讲解。
•下面以题目中的例子来说明算法:两个string分别为:abcfbc和abfca。创建一个二维数组dp[][],维数分别是两个字符串长度加一。我们定义 dp[i][j]表示s1[i-1]和s2[j-1] (注意字符串是从下标0开始的)的最长子串(LCS).当i或j等于0时,dp[i][j]=0. LCS问题存在一下递归式:
•dp[i][j] = 0                            i=0 or j=0
•dp[i][j] = dp[i-1][j-1]                 s1[i-1]= =s2[j-1]
•dp[i][j] = MAX(dp[i-1][j], dp[i][j-1])  s1[i-1] =s2[j-1]
 
为什么会是这样呢?因为字符串长度加1,会可以由3种状态转移过来,举例:之前是dp[i-1][j-1],就是是s1前i-1个字符和s2前j-1个字符匹配,要转移到dp[i][j],显然可以由dp[i][j-1]在s2上加1步得到的,也可以由dp[i-1][j]在s1的长度加1来到的,这两种都不会增加匹配数,因为只是1个串加了1,但是如果是dp[i-1][j-1]:s1,s2同时加1这时可能有新的匹配产生,若有新的匹配产生,那么在dp[i-1][j-1]加上新的匹配,若没有就需要考虑其他的两种状态。
转移方程就是dp[i][j]=s1[i-1]==s2[j-1]?dp[i-1][j-1]+1:MAX(dp[i][j-1],dp[i-1][j]); 以下是状态转移表格,箭头表示当前状态由哪个先前状态来的
 
AC代码:
#include<iostream>
#include<string>
#include<cstring>
using namespace std;

int MAX(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    string s1,s2;
    while(cin>>s1>>s2)
    {
        int len1=s1.size(),len2=s2.size(),max=0;
        int dp[len1+1][len2+1];
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=len1;i++)
        for(int j=1;j<=len2;j++)
        {dp[i][j]= s1[i-1]==s2[j-1]?dp[i-1][j-1]+1:MAX(dp[i-1][j],dp[i][j-1]);
        if(dp[i][j]>max)
        max=dp[i][j];
        }
         cout<<max<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值