PAT B1040/A1093 Count PAT's (25分)

1093 Count PAT’s (25分)

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
​5
​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT

Sample Output:
2
给定字符串中有几个PAT
这道题目如果遍历寻找P A T 的个数,时间复杂度为O(n^2)会运行超时
因此要保证在O(n) 开一个数组P[]通过一次字符串遍历 记录p的个数,再从右往左遍历记录T的值

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main()
{
    char str[100001];
    cin >> str;
    int len = strlen(str);
    int P[100001] = { 0 };//数组记录P的个数
    for (int i = 0; i < len; i++)
    {
        if (i>0)//记录当前位置前P的个数
        {
            P[i] = P[i - 1];
        }
        if (str[i] == 'P')
        {
            P[i]++;
        }
    }
    int sum = 0;
    int countT = 0;
    for (int i = len - 1; i >= 0; i--)
    {
        if (str[i] == 'T')//当前位置是T的话 T的个数加一
        {
            countT++;
        }
        else if (str[i] == 'A')
        {
            sum = (sum + P[i] * countT) % 1000000007;
        }
    }
    cout << sum << endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

VictorierJwr

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值