1093 Count PAT’s (25分)
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT’s contained in the string.
Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
5
characters containing only P, A, or T.
Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT
Sample Output:
2
给定字符串中有几个PAT
这道题目如果遍历寻找P A T 的个数,时间复杂度为O(n^2)会运行超时
因此要保证在O(n) 开一个数组P[]通过一次字符串遍历 记录p的个数,再从右往左遍历记录T的值
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main()
{
char str[100001];
cin >> str;
int len = strlen(str);
int P[100001] = { 0 };//数组记录P的个数
for (int i = 0; i < len; i++)
{
if (i>0)//记录当前位置前P的个数
{
P[i] = P[i - 1];
}
if (str[i] == 'P')
{
P[i]++;
}
}
int sum = 0;
int countT = 0;
for (int i = len - 1; i >= 0; i--)
{
if (str[i] == 'T')//当前位置是T的话 T的个数加一
{
countT++;
}
else if (str[i] == 'A')
{
sum = (sum + P[i] * countT) % 1000000007;
}
}
cout << sum << endl;
return 0;
}