1046 Shortest Distance (20 分)

1046 Shortest Distance (20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and D**N is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

Analysis

这道题不知道啥时候做的了…

Code(C++)

#include <iostream>
using namespace std;

int main()
{
    int n;
    cin >> n;
    int a[n], dis[n], total = 0;
    for(int i=0; i<n; i++)
    {
        cin >> a[i];
        total += a[i];
        
        if(i == 0)
            dis[i] = 0;
        else
            dis[i] = dis[i-1] + a[i-1];
    }
    
    int numTest;
    cin >> numTest;
    for(int i=0; i<numTest; i++)
    {
        int start, des;
        cin >> start >> des;
        
        if(start > des)
        {
            int tmp = des;
            des = start;
            start = tmp;
        }
        
        int d = dis[des-1] - dis[start-1];
        cout << min(d, total-d) << endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值