OJ第六批——Problem J: B 虚拟继承(虚基类)-沙发床(改错题)

问题及代码:

 

Problem J: B 虚拟继承(虚基类)-沙发床(改错题)

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 442   Solved: 353
[ Submit][ Status][ Web Board]

Description

 有一种特殊的床,既能当床(Bed)用又能当沙发(Sofa)用,所以叫沙发床(SleeperSofa)。

同时床和沙发又是一种特殊的家具(Furniture),具有一切家具的特性。


利用虚拟继承(虚基类)建立一个类的多重继承,沙发床继承了床和沙发的特性。


下面的程序中,在begin到end部分存在语法错误。请改正错误,使程序按下面输入输出的规定运行。

注意:只提交修改过的begin到end部分的代码。

#include <iostream>
using namespace std;

//家具类Furniture
class Furniture
{
public:
Furniture(double w)
{ weight=w; }
void display()
{
cout<<"weight:"<<weight<<endl;
}
protected:
double weight; //家具重量
};

//******************** begin ********************
//床类Bed
class Bed: public Furniture
{
public:
Bed(double we,double l,double wi):Furniture(we),length(l),width(wi){}
void display()
{
cout<<"length:"<<length<<endl;
cout<<"width:"<<width<<endl;
}
protected:
double length; //床的长
double width; //床的宽
};

//沙发类Sofa
class Sofa: public Furniture
{ public:
Sofa(double w,double h):Furniture(w),height(h){}
void display()
{
cout<<"height:"<<height<<endl;
}
protected:
double height; //沙发的高度
};

//沙发床
class SleeperSofa:public Bed, public Sofa
{public:
SleeperSofa(double we,double l,double wi,double h):Bed(we,l,wi),Sofa(we,h){ }
void display()
{
cout<<"weight:"<<weight<<endl;
Bed::display();
Sofa::display();
}
};

//********************* end ********************

int main()
{
double weight,length,width,height;
cin>>weight>>length>>width>>height;

SleeperSofa ss(weight,length,width,height);
ss.display();

return 0;
}

Input

依次输入沙发床的重量、长、宽、高  

Output

依次输出沙发床的重量、长、宽、高

Sample Input

200 1.8 1.5 1.2

Sample Output

weight:200
length:1.8
width:1.5
height:1.2

HINT

#include <iostream> 
using namespace std; 
  
//家具类Furniture 
class Furniture 
{ 
  public: 
     Furniture(double w) 
      { weight=w; } 
     void display() 
     { 
         cout<<"weight:"<<weight<<endl; 
     } 
  protected: 
    double weight; //家具重量 
}; 
class Bed:virtual public Furniture 
{ 
public: 
    Bed(double we,double l,double wi):Furniture(we),length(l),width(wi) {} 
    void display() 
    { 
        cout<<"length:"<<length<<endl; 
        cout<<"width:"<<width<<endl; 
    } 
protected: 
    double length; //床的长 
    double width; //床的宽 
}; 
  
//沙发类Sofa 
class Sofa:virtual public Furniture 
{ 
public: 
    Sofa(double w,double h):Furniture(w),height(h) {} 
    void display() 
    { 
        cout<<"height:"<<height<<endl; 
    } 
protected: 
    double height; //沙发的高度 
}; 
  
//沙发床 
class SleeperSofa:public Bed, public Sofa 
{ 
public: 
    SleeperSofa(double we,double l,double wi,double h):Furniture(we) ,Bed(we,l,wi),Sofa(we,h) { } 
    void display() 
    { 
        cout<<"weight:"<<Furniture::weight<<endl; 
        Bed::display(); 
        Sofa::display(); 
    } 
}; 
int main() 
{ 
  double weight,length,width,height; 
  cin>>weight>>length>>width>>height; 
  
  SleeperSofa ss(weight,length,width,height); 
  ss.display(); 
    
  return 0; 
} 
  


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值