1128 N Queens Puzzle (20 point(s))
The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)
Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,⋯,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.
![]() | ![]() | |
---|---|---|
Figure 1 | Figure 2 |
Input Specification:
Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4≤N≤1000 and it is guaranteed that 1≤Qi≤N for all i=1,⋯,N. The numbers are separated by spaces.
Output Specification:
For each configuration, if it is a solution to the N queens problem, print YES
in a line; or NO
if not.
Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES
题目大意:N皇后问题。。其实比较low暴力就过了。就是判断给定数组是不是N皇后问题的一个解。下标是列,值表示行。
解题思路:因为是按下标给的,所以不用考虑列了,直接考虑检查对角线和行数是否相同就行了,行的话只要判断有没有数相同就行了最高效的话直接弄个set读最后读出来如果容器大小不是K就直接NO,如果是K再去处理数组,然后判断对角线,其实就简单暴力搜索一下就行了,对于每个皇后只要遍历后续的即可,很简单的就考虑斜上和斜下两条线因为数据小这样是随便过的。
#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
int main()
{
int T;
scanf("%d", &T);
for (int i = 0; i < T; i++) {
int K;
scanf("%d", &K);
vector<int> res;
set<int> r;//检查行
for (int j = 0; j < K; j++) {
int cur;
scanf("%d", &cur);
res.push_back(cur);
r.insert(cur);
}
if (r.size() != K) {
printf("NO\n");
continue;
}
else {
bool flag = true;
for (int j = 0; j < K; j++) {
for (int m = j + 1; m < K; m++) {
if (res[m] == res[j] + m - j || res[m] == res[j] + j - m) {
flag = false;
break;
}
}
}
if (flag) {
printf("YES\n");
}
else {
printf("NO\n");
}
}
}
return 0;
}