POJ 1631 Bridging signals(最长上升序列)

面对复杂的芯片信号交叉问题,本文介绍了一种算法,旨在通过寻找最长不交叉信号序列来减少信号桥接数量,确保芯片设计的有效性和经济性。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Bridging signals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11705 Accepted: 6391

Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4
 
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int N=40000+5;
int dp[N];  //长度为i的最长上升序列的结尾最小值 
int a[N];  
int find(int len,int n)
//修改后的二分查找,若返回值为x,则a[x]>=n  
{  
    int left=0,right=len,mid=(left+right)/2;  
    while(left<=right)  
    {  
       if(n>dp[mid]) left=mid+1;  
       else if(n<dp[mid]) right=mid-1;  
       else return mid;  
       mid=(left+right)/2;  
    }  
    return left;  //如果到最后还没找到 返回最靠近左边  因为要小的 
}
int main(){
	int n,t,i,len,j;
	cin>>t;
	while(t--){
		cin>>n;
		for(i=0;i<n;i++)
		cin>>a[i];
		len=1; //已有的升序序列长度 
		dp[1]=a[0];
		for(i=1;i<n;i++){		  
            j=find(len,a[i]);  
            dp[j]=a[i];  
        if(j>len) len=j;//更新len 
		//要更新len,另外补充一点:由二分查找可知j只可能比len大1                       
		}
		cout<<len<<endl; 
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值