FatMouse's Speed

I - FatMouse's Speed
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 
 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input

     
     
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output

     
     
4 4 5 9 7
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[1005],pre[1005],ans[1005];//dp数组用来存放子列的长度,pre[i]=j代表i对应的上一个数据是j
struct node
{
    int w,l,id;//重量,速度,数据起初的序号
}s[1005];                            //存储每组数据
bool cmp(node a,node b)
{
    return a.w<b.w||(a.w==b.w&&a.l>b.l); //先对数据进行排序  按照由小到大排体重,若体重相等再排速度的规则
}

int main()
{
    int k=0;                        //k用来记录有多少只老鼠
    freopen("in.txt","r",stdin);
    while(scanf("%d%d",&s[k].w,&s[k].l)!=EOF)
    {
        s[k].id=k+1;
        pre[k]=0;           //对pre初始化
        dp[k]=1;            //对dp初始化
        k++;
    }
    int res=0,idex=0;//res用来存放最大子列长度
    sort(s,s+k,cmp);
    for(int i=0;i<k;i++)
    {
        for(int j=0;j<i;j++)
        {
            if(s[j].w<s[i].w&&s[j].l>s[i].l)
            {
                if(dp[i]<dp[j]+1)
                {
                    pre[i]=j;
                    dp[i]=dp[j]+1;      //优化
                }
            }
        }
        if(res<dp[i])
        {
            res=dp[i];
            idex=i;
        }
    }                               //idex用来记录最长子列的最后一个数据的位置
    printf("%d\n",res);
    int p=0;
    while(idex!=0)              //idex=0代表此时只有一只老鼠  或者 找到了最长子列的起始点的位置
    {
        ans[p++]=idex;
        idex=pre[idex];
    }
    if(res==1)                      //当只有一只老鼠的情况
        printf("%d\n",dp[0]);
    while(p>0)              //按照最长子列中数据位置输出
    {
        p--;
        printf("%d\n",s[ans[p]].id);
    }
    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值