九度OJ 题目1039:Zero-complexity Transposition

本文介绍了一种名为“零复杂度转置”的简单算法,该算法用于将给定的一系列整数进行反转。文章提供了两种实现方法:一种使用数组,另一种使用字符串。这两种方法都实现了题目要求的功能,并通过了相关测试。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目1039:Zero-complexity Transposition

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:1508

解决:570

题目描述:

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

输入:

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

输出:

For each case, on the first line of the output file print the sequence in the reverse order.

样例输入:
5
-3 4 6 -8 9
样例输出:
9 -8 6 4 -3
来源:
2007年上海交通大学计算机研究生机试真题
/*********************************
*   日期:2013-2-19
*   作者:SJF0115
*   题号: 九度OJ 题目1039:Zero-complexity Transposition
*   来源:http://ac.jobdu.com/problem.php?pid=1039
*   结果:AC
*   来源:2007年上海交通大学计算机研究生机试真题
*   总结:
**********************************/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int main()
{
    int i,n;
    while(scanf("%d",&n) != EOF){
        long long int a[n];
        for(i = 0;i < n;i++)
		{
            scanf("%lld",&a[i]);
		}
        for(i = n - 1;i >= 0;i--)
		{
            printf("%lld",a[i]);
            if(i == 0)
			{
				printf("\n");
			}
            else{
				printf(" ");
            }
        } 
	}
	return 0;
}
第二种方法:字符串
/*********************************
*   日期:2013-2-19
*   作者:SJF0115
*   题号: 九度OJ 题目1039:Zero-complexity Transposition
*   来源:http://ac.jobdu.com/problem.php?pid=1039
*   结果:AC
*   来源:2007年上海交通大学计算机研究生机试真题
*   总结:
**********************************/
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	string Num[10000];
	int N,i;
	while (cin>>N)
	{
		for (i=0;i<N;i++)
		{
			cin>>Num[i];
		}
		for (i=N-1;i>0;i--)
		{
			cout<<Num[i]<<" ";
		}
		cout<<Num[0]<<endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值