POJ 1007 DNA Sorting

本文介绍了一种衡量DNA序列排序性的方法,通过计算序列中逆序对的数量来判断其有序程度,并提供了C++及Java实现代码,用于对DNA字符串进行从最有序到最无序的排序。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 63725 Accepted: 25159

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

 

c++代码:

#include<iostream>
#include<cstring>
#include<cstdlib>
using namespace std;
const int MAX=105;

struct DNA{
      
  char str[55];
  int measures;    
      
};

int dlen(char *str){
    int cnt=0;
    for(int i=0;i<strlen(str);i++)
     for(int j=i+1;j<strlen(str);j++){
             if(str[i]>str[j])cnt++;
            
     }
    return cnt;
}

DNA dna[MAX];

int cmp(const void *va,const void *vb){
       
      DNA*a,*b;
      a=(DNA*)va;
      b=(DNA*)vb;
      if(a->measures > b->measures)return 1;
      else if(a->measures < b->measures)return -1;
     
      return 0;  
   
}

int main(){
   
    int len,n;
    cin>>len>>n;
    for(int i=0;i<n;i++){cin>>dna[i].str;dna[i].measures=dlen(dna[i].str);}
    qsort(dna,n,sizeof(DNA),cmp);
   
    for(int i=0;i<n;i++)cout<<dna[i].str<<endl;
     
   
  return 0;   
}

 

java代码如下:

import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main {

 private String str;
 private int cnt;

 public void len() {

  int size = str.length();
  for (int i = 0; i < size; i++)
   for (int j = i + 1; j < size; j++) {
    if (str.charAt(i) > str.charAt(j))
     this.cnt++;

   }

 }

 public Main() {
  this.cnt = 0;
 }

 public static void main(String[] args) {
  Scanner in = new Scanner(System.in);

  int len = in.nextInt();
  int n = in.nextInt();
  Main[] dnaSortings = new Main[n];
  for (int i = 0; i < n; i++) {
   dnaSortings[i]=new Main();
  }
  for (int i = 0; i < n; i++) {
   dnaSortings[i].str = in.next();
   dnaSortings[i].len();
  }
  Comparator<? super Main> c = new Comparator<Main>() {

   @Override
   public int compare(Main o1, Main o2) {
    if (o1.cnt > o2.cnt) {
     return 1;
    } else if (o1.cnt < o2.cnt) {
     return -1;

    }
    return 0;
   }
  };
  Arrays.sort(dnaSortings, c);

  for (int i = 0; i < n; i++) {
   System.out.println(dnaSortings[i].str);
  }

 }
}

 

DNA Sorting Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 34868 Accepted: 13480 Description One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. Input The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. Output Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order. Sample Input 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT Sample Output CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA Source East Central North America 1998
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值