Description
A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".
An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".
In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo".
An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car".
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate cart carburetor caramel caribou carbonic cartilage carbon carriage carton car carbonate
Sample Output
carbohydrate carboh cart cart carburetor carbu caramel cara caribou cari carbonic carboni cartilage carti carbon carbon carriage carr carton carto car car carbonate carbona
Source
听大爷们说,就是一个裸的trie树,萌新表示瑟瑟发抖。
似乎也不难,就是记录一个数组t[i][j]表示父亲节点是i,这个节点存储的字母是j时的节点。
还需要记录经过这个节点的单词有多少个。
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int N=1005;
int cnt,sz,t[5005][35],s[5005];
char a[N][31];
void insert(char ch[])
{
int len=strlen(ch+1),now=0;
for(int i=1;i<=len;i++)
{
int k=ch[i]-'a';
if(t[now][k]==0)
t[now][k]=++sz;
now=t[now][k];
s[now]++;
}
}
void ask(char ch[])
{
int now=0,len=strlen(ch+1);
for(int i=1;i<=len;i++)
{
if(s[now]==1)
break;
int k=ch[i]-'a';
printf("%c",ch[i]);
now=t[now][k];
}
}
int main()
{
while(~scanf("%s",a[++cnt]+1))
insert(a[cnt]);
for(int i=1;i<=cnt;i++)
{
printf("%s ",a[i]+1);
ask(a[i]);
printf("\n");
}
return 0;
}