Simpsons’ Hidden Talents(辛普森一家的隐藏天赋 )(kmp经典模板题) HDU - 2594

题目:Simpsons’ Hidden Talents(辛普森一家的隐藏天赋 )


Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
Sample Input
clinton
homer
riemann
marjorie
Sample Output
0
rie 3

中文大意

荷马:玛吉,我只是想出了一种方法来发现我们不知道的一些才能。
玛吉:是啊,怎么了?
荷马:以我为例。我想知道我是否有政治才能,好吗?
玛吉:好的。
荷马:所以我取一些政治家的名字,比如克林顿,并尝试找出
克林顿名字中最长前缀的长度, 即我名字中的后缀。这就是我与克林顿
玛吉这样的政治家有多接近 :为什么选择最长的前缀作为后缀???
荷马:嗯,我们的才能深深地隐藏在我们自己的内心深处,玛吉。
玛吉:那你离得有多近?
荷马:0!
玛吉:我并不感到惊讶。
荷马:但是你知道,你内心深处一定隐藏着一些真正的数学天赋。
玛吉:怎么会?
荷马:黎曼和玛乔丽给了 3 个!!!
玛吉:黎曼到底是谁?
荷马:没关系。
编写一个程序,当给定字符串 s1 和 s2 时,找到 s1 的最长前缀,即 s2 的后缀。
输入
输入由两行组成。第一行包含 s1,第二行包含 s2。你可以假设所有的字母都是小写的。
输出
输出包含一行,其中包含最长的字符串,前缀为 s1,后缀为 s2,后跟该前缀的长度。如果最长的此类字符串是空字符串,则输出应为 0。
s1 和 s2 的长度最多为 50000。
样本输入
克林顿
荷马
黎曼
玛乔丽
样本输出
0
rie 3
解题思路: 首先给你两个字符串,如果第二串的后缀中包含第一串的最长前缀,输出这个最长前缀,同时输出这个前缀的长度。本题的解题思路就是先把两个串前后连在一起,合体成为一个串,求出合体后的next数组,利用数组进行判断。
while(ans>min(tp,plen-tp))//如果合体之后比其中任何一个大
ans=Next[ans];//说明是合体后产生的,不可取
这里是本题的一个关键语句,可联想next数组多多思考。

#include<bits/stdc++.h>
using namespace std;
int Next[100020];
char str[100020];
char ptr[100021];
int slen,plen;

void gtNext()
{
	int k=-1;int j=0;
	while(j<plen)
	{
		if(k==-1||ptr[j]==ptr[k])
		{
			j++;k++;
			Next[j]=k;
		}
		else k=Next[k];
	}
	return ;
}

int main()
{
	int cnt;
	while(scanf("%s%s",ptr,str)!=EOF)
	{
		slen=strlen(str);
		plen=strlen(ptr);
		int tp=plen;
		for(int i=plen; i<slen+plen; i++)
			ptr[i]=str[i-plen];//俩串合体 
		plen=plen+slen;
		ptr[plen]='\0';//合体后会多一个,变成空 
		Next[0]=-1;
		gtNext();
		int ans=Next[plen];//next最后一个值即为串的最大前后缀的值 
		while(ans>min(tp,plen-tp))//如果合体之后比其中任何一个大 
			ans=Next[ans];//说明是合体后产生的,不可取 
		if(ans==0)
		{
			cout<<"0"<<endl;
			continue;
		}
		for(int i=0; i<ans; i++)
			printf("%c",ptr[i]);
		cout<<" ";
		cout<<ans<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值