PAT A1083 List Grades (25分)

本文介绍了一种算法,用于对学生记录进行排序并筛选出特定分数区间内的学生信息。通过使用结构体数组和自定义比较函数,可以实现对学生记录的高效处理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:
N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE

题意:

输入学生总数,然后逐行输入学生姓名、id、分数,再输入允许输出的最低分和最高分;输出分数在最低分和最高分之间的学生的姓名和id,如果不存在这样的学生则输出NONE.(题目没有指定N的范围;题目保证每个学生的分数都不相同.)

思路:

(1)开设一个student结构体数组stu[],包含name、id和grade;
(2)先对所有学生进行排序,再遍历整个数组进行判断,对分数满足条件的学生输出.

代码:

#include <cstdio>
#include <algorithm>
using namespace std;

struct student{
	char name[15],id[15];
	int grade;
}stu[100010];
bool cmp(student a,student b){
	return a.grade>b.grade;
}

int main(){
	int N;
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		scanf("%s %s %d",stu[i].name,stu[i].id,&stu[i].grade);
	}
	int grade1,grade2;
	scanf("%d %d",&grade1,&grade2);
	sort(stu,stu+N,cmp); 
	int input = false;//记录是否存在分数在最低分和最高分之间的学生 
	for(int i=0;i<N;i++){
		if(stu[i].grade>=grade1&&stu[i].grade<=grade2){
			printf("%s %s\n",stu[i].name,stu[i].id);
			input = true;
		}
	}
	if(input==false) printf("NONE\n");
	return 0;
}

词汇:

interval 间隔
distinct 不同的

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值