Light oj--1116

Description

Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share ofN square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4


解题思路:当W为奇数时,肯定输出的是Impossible,所以只要讨论当W为偶数时.又应为M要尽可能小,所以只有当M为2的幂方时,此时M不能分解,(因为N为奇数),为所求的最小值.



代码如下:

#include<stdio.h>
#include<string.h>
#include<cmath>
int main(){
	int t,cas;
	cas=1;
	long long w,s;
	scanf("%d",&t);
	while(t--){
		scanf("%lld",&w);
		if(w%2){
		     printf("Case %d: Impossible\n",cas++);
		     continue;
		}
		s=w;
	    while(s%2==0){
	    	s=s/2;
	    }
		printf("Case %d: %lld %lld\n",cas++,s,w/s);
	}
	return 0;
}


.

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值