hdu1171 Big Event in HDU --01背包

本文针对一个具体的设施分配问题,提供了一种通过动态规划求解最优解的方法。问题要求将不同种类和数量的设施等价地分配给两个学院,并确保两者的总价值尽可能接近且前者不低于后者。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1171


一:原题内容

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 
Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1

Sample Output
  
  
20 10 40 40
 
二:分析理解

直接看代码就懂 了。


三:AC代码

#include<iostream>  
#include<algorithm>  

using namespace std;

int va[5005];
int dp[250005];
int a, b;
int n;

int main()
{
	while (~scanf("%d", &n) && n > 0)
	{
		memset(dp, 0, sizeof(dp));

		int sum = 0;
		int num = 1;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &a, &b);
			while (b--)
			{
				va[num++] = a;
				sum += a;
			}
		}

		for (int i = 1; i < num; i++)
			for (int j = sum / 2; j >= va[i]; j--)
				dp[j] = max(dp[j - va[i]] + va[i], dp[j]);

		printf("%d %d\n", sum - dp[sum / 2], dp[sum / 2]);
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值