POJ 1469 Course
题目链接:POJ 1469 Course
Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
- every student in the committee represents a different course (a student can represent a course if he/she visits that course)
- each course has a representative in the committee
Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student 1 1 Student 1 2 … Student 1 Count1
Count2 Student 2 1 Student 2 2 … Student 2 Count2
…
CountP Student P 1 Student P 2 … Student P CountPThe first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
The result of the program is on the standard output. For each input data set the program prints on a single line “YES” if it is possible to form a committee and “NO” otherwise. There should not be any leading blanks at the start of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
Sample Output
YES
NO
题意:
一共有N个学生和P门课程,一个学生可以任意选一门或多门课, 是否能达到:每门课程都能匹配到选该课程的学生(一个学生只能代表一门课程)
AC代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <locale>
#include <vector>
#include <string>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <functional>
using namespace std;
bool used[305];
int pipei[305][305];
int link[305];
int N,P;
int dfs(int x)
{
for(int i=0; i<=N; i++)
{
if(!used[i]&&pipei[x][i])
{
used[i]=true;
if(link[i]==0||dfs(link[i]))
{
link[i]=x;
return true;
}
}
}
return false;
}
int Hungary()
{
int ans=0;
for(int i=1; i<=N; i++)
{
memset(used,0,sizeof used);
if(dfs(i))
ans++;
}
return ans;
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
memset(pipei,0,sizeof pipei);
memset(link,0,sizeof link);
memset(used,0,sizeof used);
scanf("%d%d",&P,&N);
for(int i=1; i<=P; i++)
{
int x;
scanf("%d",&x);
while(x--)
{
int j;
scanf("%d",&j);
pipei[i][j]=1;
}
}
if(Hungary()==P)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}