【[kuangbin]数学训练一】K - Largest Box 【霖行】

【[kuangbin]数学训练一】K - Largest Box 【霖行】

题目:

K - Largest Box

In the following figure, you can see a rectangular card. The width of the card is W, length of the card is L and thickness is zero. Four (x*x) squares are cut from the four corners of the card shown by the black dotted lines. Then the card is folded along the red lines to make a box without a cover.

Box

Given the width and height of the box, you will have to find the maximum volume of the box you can make for any value of x.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two real numbers L and W (0 < L, W < 100).

Output

For each case, print the case number and the maximum volume of the box that can be made. Errors less than 10-6 will be ignored.

Sample Input

3
2 10
3.590 2.719
8.1991 7.189

Sample Output

Case 1: 4.513804324
Case 2: 2.2268848896
Case 3: 33.412886

题目大意:

有一个长为L宽为W的矩形,在矩形的四角上分别截去一个边长为x的正方形,然后拼成一个盒子。问盒子最大体积。

题目分析:

利用逼近法,不断找出体积较大的x值,直到误差允许。

代码:

#include<iostream>
using namespace std;

double V(double L, double W, double X)
{
	return W * L * X - 2 * X * X * (W + L) + 4 * X * X * X;
}

int main()
{
	int T; cin >> T;
	for (int i = 1; i <= T; i++)
	{
		double L, W; cin >> L >> W;
		double l = 0, r = min(L, W) / 2, mid, mm;
		while (r - l >= 0.000000001)
		{
			mid = (l + r) / 2;
			mm = (mid + r) / 2;
			if (V(L, W, mid) >= V(L, W, mm))
				r = mm;
			else
				l = mid;
		}
		printf("Case %d: %lf\n", i, V(L, W, mid));
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

霖行

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值