HDU 1241 Oil Deposits

本文介绍了一种用于探测地下油藏分布的算法。通过网格划分土地并使用深度优先搜索(DFS)来确定不同油藏的数量。算法实现了对每个可能含有油藏的地块的遍历,避免重复搜索,并统计独立油藏的总数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

 

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

 

 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

 

Sample Input

 

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

 

0

1

2

2

解题思路:

               一个简单的深搜,之前的深搜要求的是深搜路径或者是否存在特定情况,而本题要求的是进行了几次最外层的深搜。

直接把flag地图数组搜过的情况进行标记,就不会出现重复搜索的情况了。

#include<iostream>
#include<queue>
#include<string.h>
#include<cstring>
#include<cstdio>
using namespace std;
char flag[101][101];///地图数组
int ans, n, m, direction[8][2] = { {-1,0},{1,0},{0,-1},{0,1},{-1,-1},{-1,1},{1,-1},{1,1} };///代表可以移动的八个方向,一行代表一个方向,通过改变当前位置的坐标来实现移动
void dfs(int i,int j)
{
    int x,y;
    for(int h=0; h<8; h++)
    {
        flag[i][j]='*';///把走过的位置标记为'*',防止重复搜索
        x=i+direction[h][0];
        y=j+direction[h][1];//方向的移动,(实在不理解的可以用笔写一下h的各个情况)
        if((x>=0&&x<n)&&(y>=0&&y<m)&&(flag[x][y]=='@'))///判断移动过的点是否符合要求
        {
            dfs(x,y);///说明下一步与当前的属于同一块油田,继续搜索
        }
    }
}
int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        if(n==0&&m==0) break;
        ans=0;
        for (int i = 0; i < n; i++)
            for (int j = 0; j < m; j++)
                cin>>flag[i][j];
        for (int i=0; i<n; i++)
            for (int j=0; j<m; j++)
                if (flag[i][j]=='@')///遇见一个新的'@'即为一块新的油田,ans++,同时深搜把搜过的路径标记
                {
                    dfs(i,j);
                    ans++;
                }
        cout<<ans<<endl;
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值