杭电(hdu)ACM 1010 Tempter of the Bone

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 90328    Accepted Submission(s): 24554


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 
又是一道搜索题目,使用深度优先搜索,注意要添加剪枝条件,不然很容易造成超时,同时做搜索题要注意回溯,举个例子,若是求经典问题--油田的块数,我们不需要回溯,但是本题是求路径,我们需要用到回溯,不然会答案错误的,这是由于求油田块数的话,我们遍历了,不需要再次遍历,而求路径的话,若是求得的路径不通,需要将标记的路径还原,回溯很重要!!!!
本题代码如下:
#include <iostream>
#include <string>
#include <cmath>
#include <cstring>
using namespace std;

int N,M,T,escape,wall;
int starti,startj,endi,endj;
char map[101][101];
int v[101][101];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y,int time)
{
    if(abs(endi-x)+abs(endj-y)>T-time)return;
    if((abs(endi-x)+abs(endj-y))%2!=(T-time)%2)return;
    if(x==endi&&y==endj&&time==T)escape=1;
    if(escape==1)return;
    for(int i=0;i<=3;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx>=1&&xx<=N&&yy>=1&&yy<=M&&map[xx][yy]!='X'&&v[xx][yy]==0)
        {
            v[xx][yy]=1;
            dfs(xx,yy,time+1);
            v[xx][yy]=0;   //回溯 
        }
    }
    return; 
}
int main()
{
    while(cin>>N>>M>>T,N||M||T)
    {
        wall=0;
        memset(v,0,sizeof(v));
        for(int i=1;i<=N;i++)
            for(int j=1;j<=M;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='S')
                {
                    starti=i;
                    startj=j;
                }
                else if(map[i][j]=='X')
                {
                    wall++;
                }
                else if(map[i][j]=='D')
                {
                    endi=i;
                    endj=j;
                }
            }
        v[starti][startj]=1;
        escape=0;
        dfs(starti,startj,0);
        if(N*M-wall<T){cout<<"NO"<<endl;continue;}
        if(escape==1)cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值