一个用Delphi做的SIP Stack(协议栈)和软电话与网关的网站有源码的哦

语音聊天实现(Delphi) 语音聊天实现没有通过Acm控件的,比较长,有兴趣的可以看一下,还有通过UDP的聊天功能。unit Unit1;interfaceuses  Windows, Messages, SysUtils, Classes, Graphics, Controls, Forms, Dialogs,  StdCtrls, NMUDP, CheckLst,winsock, ElTree,ElHeade 阅读详情

地址:http://www.ictrnid.org.uk/index.html?softlib.html

the source code for an RFC3261 SIP stack, a RFC3550 RTP stack and SDP (RFC2327) parsing and utilities. Please note this is a work in progress. Uses DUnit testing framework. Last updated 7 February 2006

 

 

DELPHI实现SIP协议示例程序详解 SIP(Session Initiation Protocol)是一种基于文本的应用层信令协议,用于建立、修改和终止多媒体通信会话,如VoIP通话、视频会议和即时消息传输。其设计基于客户端-服务器模型,支持灵活的网络拓扑和扩展性,广泛应用于现代实时通信系统中。本章将从SIP的协议架构入手,剖析其在OSI模型中的定位,并逐步解析SIP的核心功能组件,如。 阅读详情

相关推荐

Delphi SIP客户端调用程序

相关组件我会一一上传,请去查看资源列表。测试了,调试下可以用

纯软的SIP语音服务器API

以前的语音服务器如呼叫中心、IVR等应用,一般是用语音板卡完成,如三汇和东进的数字卡,模拟卡。如今软交换是趋势,有的运营商甚至可以提供基于IMS的sip中继,再使用语音卡就不合适了。纯软的语音系统,部署起来也简单,只要弄一台普通的PC或服务器就可以,录音也存放在该机器上。 我们自己开发的SIP协议栈和媒体库,久经考验,封装出API给开发者使用,特点如下: 1、API很简单,只有20来个

朱东宁的专栏 6653

Delphi基于sip协议呼叫中心客户端

摘要:Delphi源码,网络相关,呼叫中心,sip协议  Delphi基于sip协议呼叫中心客户端源码,已成功应用于商业项目中,此客户端,可以注册在sip协议上进行语音通话。

Delphi写的IP电话源码

Delphi写的IP电话源码

Delphi基于sip协议呼叫中心客户端源码

Delphi源码,网络相关,呼叫中心,sip协议   Delphi基于sip协议呼叫中心客户端源码,已成功应用于商业项目中,此客户端,可以注册在sip协议上进行语音通话。

自写的完整SIP协议栈(c源码),编译后即可应用

处于学习价段的同志,请配合我所发布的sip学习资料学习,会收到事半功倍的效果。 堪入式linux 的 sip 协试栈。 主要应用于网关。 用得着的人士可参考。 有兴趣的人士可交流。想接触VOIP的人士可学习。

SIP 开发 DELPHI 源码

SIP 开发 DELPHI,全部源码 SIP的开发代码

delphi sip 协议及测试程序

稍作修改的sip 协议 stack. 可以编译通过并发送和接收呼叫信息

IP地址转换DELPHI

function IpStrToU(sIp:AnsiString):DWORD; begin Result:=inet_addr(pAnsiChar(sIp)) end; function IpUToStr(U:Dword):AnsiString; var inaddr: TInAddr; //sin:sockaddr_in; begin //sin.sin_addr.S_addr:=U; inaddr.S_addr:=U; Result:=StrPas(inet_ntoa(inaddr)) end;

微码信息 6万+

网络IP电话源码及所用delphi控件v1.4

网络IP电话源码,及所用delphi控件(v1.4),仅供学习

Delphi写的MediaRing Talk网络电话拨号器(源码)

Delphi写的MediaRing Talk网络电话拨号器(源码) 自动拨号 Delphi源码

IPWorks VoIP 2024 Delphi Crack

IPWorks VoIP 2024 for Delphi 一个简单的 VoIP 库,支持常见的 SIP 和 IVR 操作。为个人和电话会议解决方案创建高级 CTI 应用程序。

控件与插件之大全 608

Delphi6/7 SIP-0.6协议栈

The package in the ZIP file below contains the Delphi source code for a SIP stack.

使用SIP对C库进行Python封装

2019独角兽企业重金招聘Python工程师标准>>> ...

weixin_34032621的博客 262

SIP DELPHI DEMO

一个简单的DELPHI SIP 例子,是入手学习 SIP 的好东东。

SIP协议分析工具

SIP协议交互分析有助于使用者深入发解SIP协议交互特性。

Delphi sgcWebSockets 的 WebSockets简单使用

最近在项目中使用到了Websocket,开始想自己写,懒了, 觉得还是不要造车轮了,于是找到了sgcWebSockets。Demo简单,连接也简单。 用的是 delphi2007 +sgcWebSockets v2.3 WSClient_Eye.Host := sIP; WSClient_Eye.Port := sPort; WSClient_Eye.Active := True...

红枫叶随风的专栏 1万+

Cisco Packet Tracert 无线路由器配置

Cisco Packet Tracert 无线路由器配置

yushan_caoyu的博客 2万+
上一篇: 连载了解SIP协议翻译文章[IOKE作品]
下一篇: 站内搜索
老白
博客等级 码龄23年 59粉丝 106原创
评论 2
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值