hdu2199

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 


本来是按直接暴力打的,但是一直WA。后来百度了一下发现二分居然可以按照精度查!


#include<iostream>
#include<stdlib.h>
#include<string>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
double sen(double m){
    return    8*m*m*m*m + 7*m*m*m + 2*m*m + 3*m + 6; 
}
double bs(double x){
    double l=0,r=100,mid=(l+r)/2;
    while(fabs(sen(mid)-x)>1e-5){
        mid=(l+r)/2;
        if(sen(mid)>x)r=mid-1e-5;
        else l=mid+1e-5;
    }
    return mid;
}
int main(){
#ifdef LOCAL
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif
    int T;
    cin>>T;
    while(T--){
        double x;
        cin>>x;
        if(x<sen(0)||x>sen(100))printf("No solution!\n");
        else {
            double ans=bs(x);
            printf("%.4lf\n",ans);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值