HDU 1789 Doing Homework again 贪心

本文介绍了一个经典的作业调度问题,目标是在有限的时间内通过合理安排作业顺序,最小化因超过截止日期而产生的扣分。文章提供了完整的代码实现,并解释了其背后的算法思想。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Doing Homework again

                                                                      Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                                   Total Submission(s): 10615    Accepted Submission(s): 6229


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

题意:有 t 组测试数据,每组测试数据中有 n 门功课,下面第一行为它们的截止日期,第二行是未在截至的时间内完成作业要扣除的分数,然后是如何安排写作业的顺序使扣的分数最少。

思路:以前做过一遍,现在又忘了,断断续续一周的时间没有搞定。西八!对分数按从大到小排次序,然后枚举限定的时间,若是某一天没有被标记,就用这一天来完成这一门作业,若是枚举到0了,说明在限定时间内没有哪一天可以完成这门作业,那么就扣除这门课的分数......

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 1000 + 10;
int vis[MAXN];
struct Work
{
    int deadline, redsco;
    bool operator < (const Work& t) const   //按扣分从大到小排序
    {
        return redsco > t.redsco;
    }
} work[MAXN];

int main()
{
    int t, n;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d", &n);
        for (int i = 0; i < n; i++) scanf("%d", &work[i].deadline);
        for (int i = 0; i < n; i++) scanf("%d", &work[i].redsco);
        sort(work, work + n);
        memset(vis, 0, sizeof(vis));
        int ans = 0;
        for (int i = 0; i < n; i++)
        {
            int ok = 0;             //判断在截止日期前能否完成
            for (int day = work[i].deadline; day >= 1; day--)
                if (!vis[day])      //在这一天完成了!!!
                {
                    vis[day] = 1;
                    ok = 1;
                    break;
                }
            if (ok == 0) ans += work[i].redsco; //未完成作业
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值