POJ 1703 并查集

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41878 Accepted: 12868

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题意:城市里有两伙罪犯,如果是D[ a ][ b ],则代表a和b是不同伙的罪犯;如果是D[ a ][ b ],则输出a和b的关系。

思路:并查集,是那道超经典并查集例题 “ 食物链 ” 的简化版,当时做那道 “ 食物链 ” 时了解了两种思路:一是来自watashi菊苣译得那本《挑战程序设计竞赛》的用三个集合来代表三种组织;二是网上流传的方法,用一个带权并查集来表示,其中权值代表各结点和祖先的关系。

这道题我用的是watashi译书中的方法,但由于有两个团伙,所以开数组时要X2,1——N表示一个组织,N+1——2N表示另一个组织。


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int fa[200005],rank[200005];
int find(int x)
{
    if(x==fa[x])
        return x;
    else
        return fa[x]=find(fa[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)
        return;
    if(rank[x]<rank[y])
        fa[x]=y;
    else
    {
        fa[y]=x;
        if(rank[x]==rank[y])
            rank[x]++;
    }
}
int main()
{
    //freopen("D:\\in.txt","r",stdin);
    int T;
    char ch[2];
    scanf("%d",&T);
    while(T--)
    {
        int m,n;
        scanf("%d%d",&n,&m);
        for(int i=0;i<=2*n;i++)
        {
            fa[i]=i;
            rank[i]=0;
        }
        int x,y,cc;
        while(m--)
        {
            scanf("%s%d%d",ch,&x,&y);
            getchar();
            if(ch[0]=='D')
            {
                unite(x,y+n);
                unite(x+n,y);
            }
            else if(ch[0]=='A')
            {
                if(find(x)!=find(y)&&find(x)!=find(y+n))
                    printf("Not sure yet.\n");
                else if(find(x)==find(y)||find(x+n)==find(y+n))
                    printf("In the same gang.\n");
                else if(find(x)==find(y+n)||find(x+n)==find(y))
                    printf("In different gangs.\n");
            }
        }
    }
    return 0;
}



《C++编程实例100篇》是一本深入实践、极具价值的编程教程,它针对C++编程语言提供了丰富的实例,旨在帮助读者更好地理解和掌握C++的各项特性与编程技巧。这本书的经典之处在于它将理论与实践相结合,通过100个精心设计的编程实例,覆盖了C++的各个核心领域,包括基础语法、面向对象编程、模板、异常处理、STL(标准模板库)等。 我们来探讨C++的基础语法。C++是C语言的增强版,它保留了C语言的高效性和灵活性,并引入了类、对象和继承等面向对象编程概念。基础语法包括变量声明、数据类型、运算符、控制结构(如if语句、for循环、while循环)、函数的定义和调用等。在实例中,你可能会遇到如何编写简单的程序,如计算两个数的和,或者实现一个简单的猜数字游戏。 C++的面向对象编程是其一大特色。通过类和对象,你可以构建复杂的软件系统。类是对象的蓝图,它定义了对象的属性和行为。实例化一个类,就是创建一个具体的对象。继承允许你创建新的类,这些类从现有的类派生,共享其属性和方法,同时可以添加新的功能。多态性是面向对象的另一个关键特性,它使得不同类型的对象可以对同一消息作出不同的响应。这些概念在实例中会以各种形式展现,例如设计一个图形界面的类层次,或实现一个简单的模拟游戏。 接下来是模板,C++的模板功能让代码更加通用,可以处理不同类型的数据。模板分为函数模板和类模板,前者可以创建泛型函数,后者可以创建泛型类。通过模板,你可以编写出高效且灵活的代码,比如实现一个通用的排序算法。 异常处理是C++中用于处理程序运行时错误的机制。当程序出现异常情况时,可以抛出一个异常,然后在适当的点捕获并处理这个异常。这使得代码能够优雅地处理错误,而不是让程序崩溃。实例中可能会有涉及文件操作或网络通信时可能出现的异常处理示例。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值