Romantic
Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
77 51 10 44 34 79
Sample Output
2 -3 sorry 7 -3
Author
yifenfei
Source
Recommend
lcy
分析:裸的扩展欧几里德
#include<stdio.h>
#include<string.h>
long long kzgcd(long long a,long long b,long long &x,long long &y)
{
if(b==0)
{
x=1;
y=0;
return a;
}
long long ans=kzgcd(b,a%b,x,y);
long long t=x;
x=y;
y=t-(a/b)*y;
return ans;
}
long long solve(long long a,long long b,long long &x,long long &y)
{
long long gcd=kzgcd(a,b,x,y);
if(1%gcd)
return -1;
b/=gcd;
a/=gcd;
if(a<0) a=-a;
if(b<0) b=-b;
x%=b;
y%=a;
if(x<=0)
x+=b;
if(y>=0)
y-=a;
return gcd;
}
int main()
{
long long a,b;
while(scanf("%lld%lld",&a,&b)==2)
{
long long x,y;
long long ans=solve(a,b,x,y);
if(ans==-1)
printf("sorry\n");
else
printf("%lld %lld\n",x,y);
}
}