Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.
FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
Input
There are several test cases. Each test case consists of a line containing two integers between 1 and 100: n and k n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on. The input ends with a pair of -1’s.
Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37
思路
记忆化DFS题目的目的是求出最多能吃到多少奶酪吗,用搜索来找,如果不添加记忆数组将之前搜索过的坐标值答案存储下来,搜索的过程中很多重复地方,用数组可以大大节约耗时,要注意的时数组要清空,因为没清空错了好几遍。
AC代码
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int n,k;
int map[105][105];
int ans[105][105];
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
bool check(int x,int y){
if(x<0||y<0||x>=n||y>=n){
return false;
}
return true;
}
int dfs(int x,int y){
int cheese=0;
if(ans[x][y]){
return ans[x][y];
}
for(int i=0;i<4;i++){
for(int j=1;j<=k;j++){
int tx=x+dir[i][0]*j;
int ty=y+dir[i][1]*j;
if(check(tx,ty)&&map[tx][ty]>map[x][y]){
cheese=max(cheese,dfs(tx,ty));
}
}
}
ans[x][y]=cheese+map[x][y];
return ans[x][y];
}
int main(){
while(scanf("%d %d",&n,&k)!=EOF){
if(n==-1&&k==-1){
break;
}else{
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
scanf("%d",&map[i][j]);
}
}
memset(ans,0,sizeof(ans));
printf("%d\n",dfs(0,0));
}
}
return 0;
}