1043. 输出PATest(20)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee

#include <iostream>
#include <string>
#include <algorithm>

using namespace std;

int Count(string &a,char c)
{
    int count=0;
    int len=a.length();
    for(int i=0;i<len;i++)
    {
        if(c==a[i])
            count++;
    }
    return count;
}

int main()
{
    string str;
    cin>>str;
    int s[6];
    s[0]=Count(str,'P');
    s[1]=Count(str,'A');
    s[2]=Count(str,'T');
    s[3]=Count(str,'e');
    s[4]=Count(str,'s');
    s[5]=Count(str,'t');
    int max=0;
    for(int i=0;i<6;i++)
    {
        if(s[i]>max)
            max=s[i];
    }
    for(int i=0;i<max;i++)
    {
        if(s[0]>0)
            {
                cout<<"P";
                s[0]--;
            }
        if(s[1]>0)
            {
                cout<<"A";
                s[1]--;
            }
        if(s[2]>0)
            {
                cout<<"T";
                s[2]--;
            }
        if(s[3]>0)
            {
                cout<<"e";
                s[3]--;
            }
        if(s[4]>0)
           {
                cout<<"s";
                s[4]--;
           }
        if(s[5]>0)
            {
                cout<<"t";
                s[5]--;
            }
    }
    return 0;
}
Aden:计算出六个字母各自的个数,按顺序输出,每输出一个,个数减1,若为零则不输出,未输出完的继续按顺序输出
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值