分组背包

1、HDU1712

题意:有n门课程,和m天时间,完成a[i][j]得到的价值为第i行j列的数字,求最大价值......

思路:分组背包,就是第n门课程,可以做一天,可以做两天,但它们相斥,你做了一天,就不能再做一天...也就是不能再做这门课程了......

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define ll long long
#define INF 0x3f3f3f3f
#define qx std::ios::sync_with_stdio(false)
using namespace std;
int a[200][200],f[10000];
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m)){
        memset(f,0,sizeof f);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                cin>>a[i][j];
            }
        }
        for(int i=1;i<=n;i++){
            for(int j=m;j>=0;j--){
                for(int k=1;k<=m;k++){
                    if(j>=k){
                        f[j]=max(f[j],f[j-k]+a[i][k]);
                    }
                }
            }
        }
        cout<<f[m]<<endl;
    }
    return 0;
}

2、HDU3033

Problem Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

 

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

 

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

 

Sample Input

5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66

 

Sample Output

255

最少选一个,和分组背包最多选一个相反

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 105;
int n, m, K;
int dp[MAX][10005];
 
struct DATA {
    int b, p, val;
}d[MAX];
 
int main() {
    while(scanf("%d %d %d", &n, &m, &K) != EOF) {
        for (int i = 0; i < n; i ++) {
            scanf("%d %d %d", &d[i].b, &d[i].p, &d[i].val);
        }
        memset(dp, -1, sizeof(dp));
        for (int j = 0; j <= m; j ++) {
            dp[0][j] = 0;
        }
        for (int k = 1; k <= K; k ++) {
            for (int i = 0; i < n; i ++) {
                if (d[i].b == k) {
                    for (int j = m; j >= d[i].p; j --) {
                        if (dp[k][j - d[i].p] != -1) {
                            dp[k][j] = max(dp[k][j], dp[k][j - d[i].p] + d[i].val);
                        }
                        if (dp[k - 1][j - d[i].p] != -1) {
                            dp[k][j] = max(dp[k][j], dp[k - 1][j - d[i].p] + d[i].val);
                        }
                    }
                }
            }
        }
        if (dp[K][m] == -1) {
            printf("Impossible\n");
        }
        else {
            printf("%d\n", dp[K][m]);
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值