PAT:A1011 World Cup Betting (20 分)

本文介绍了一个简单的投注策略,用于最大化中国足球彩票“TripleWinning”游戏中的收益。通过选择三场比赛并针对每场比赛可能的结果(胜、平、负)下注,文章详细解释了如何计算最大利润,并提供了一个示例来展示最佳投注方案的选择过程。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

PAT:A1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

代码:

C/C++:

#include<stdio.h>
char a[3] = {'W','T','L'};

int main() {
    double mon = 1.0, temp, a1;
	int idx;
	for(int i = 0; i < 3; i++) {
		temp = 0.0;
		for(int j = 0; j < 3; j++){ 
            scanf("%lf", &a1);
            if(a1 > temp){
                temp = a1;
                idx = j;
            } 
        }
		mon *= temp;
		printf("%c ", a[idx]);
	}
	mon = (mon*0.65 -1) * 2;
	printf("%.2f", mon);
	return 0;
}

Java:

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String win = "WTL";
        double num = 1.0, money, temp;
        int idx = 0;
        double[] a = new double[3];
        for(int i = 0; i < 3; i++) {
            double max = 0;
            for(int j = 0; j < 3; j++) {
                temp = in.nextFloat();
                if(temp > max) {
                    max = temp;
                    idx = j;
                }
            }
            System.out.print(win.charAt(idx) + " ");
            num *= max;
        }
        money = (num * 0.65 - 1) * 2;
        System.out.printf("%.2f", money);
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值