HDOJ 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23736    Accepted Submission(s): 14354


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
 
 
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
 
 
45 59 6 13
 

Source
 

Recommend
Eddy
 

#include<stdio.h>
char map[25][25];
int visit[25][25],W,H;
void dfs(int x,int y)
{
	//if(map[x][y]=='.'&&visit[x][y]==0)
	if(visit[x][y]==0)
	{
		visit[x][y]=1;
		if(x-1>=0&&map[x-1][y]=='.')//向上搜索 
		dfs(x-1,y);
		if(x+1<H&&map[x+1][y]=='.')//向下搜索
		dfs(x+1,y);
		if(y-1>=0&&map[x][y-1]=='.')//向左搜索
		dfs(x,y-1);
		if(y+1<W&&map[x][y+1]=='.')//向右搜索
		dfs(x,y+1);
	}
} 
int main()
{
	int m,n;
	while(scanf("%d %d",&W,&H)!=EOF&&W!=0&&H!=0)
	{
		getchar();
		for(int i=0;i<H;i++)
		{	
			for(int j=0;j<W;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='@')
				{
					m=i;
					n=j;
				}
				visit[i][j]=0;//表示该点还没有计算过 
			}
			getchar();
		}
		dfs(m,n);
		int ans=0;
		for(int i=0;i<H;i++)
		for(int j=0;j<W;j++)
		if(visit[i][j]==1)
		ans++;
		printf("%d\n",ans);
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值