HDU 5444 Elven Postman (二叉树)

本文解析了ElvenPostman问题,介绍了如何通过构建二叉树模型并利用递归算法来解决邮件递送路径的问题。文章详细解释了输入输出样例,并提供了完整的代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5444


题面:

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 84    Accepted Submission(s): 49


Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

 

Input
First you are given an integer  T(T10)  indicating the number of test cases.

For each test case, there is a number  n(n1000)  on a line representing the number of rooms in this tree.  n  integers representing the sequence written at the root follow, respectively  a1,...,an  where  a1,...,an{1,...,n} .

On the next line, there is a number  q  representing the number of mails to be sent. After that, there will be  q  integers  x1,...,xq  indicating the destination room number of each mail.
 

Output
For each query, output a sequence of move ( E  or  W ) the postman needs to make to deliver the mail. For that  E  means that the postman should move up the eastern branch and  W  the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
 

Sample Input
  
  
2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
 

Sample Output
  
  
E WE EEEEE
 

Source

题目大意:

    给定一序列,该序列是这样得到的,每次都从根节点出发,按从小到大的顺序访问每个节点,每次都输出路径上之前没有访问过的点。


解题:

    其实这就是二叉树,第一个数是根节点,随后插入所有点,然后访问要求访问的点,输出访问的方向即可。


代码:

#include<iostream>
using namespace std;
struct node
{
	int lef,rig,val;
}store[1010];
int p;
void init(int x)
{
	p=1;
	for(int i=1;i<=x;i++)
		store[i].lef=store[i].rig=0;
}
void insert(int x)
{
	int pos=1;
	while(1)
	{
		if(x<store[pos].val)
		{
			if(!store[pos].rig)
			{
				store[pos].rig=++p;
				store[p].val=x;
				break;
			}
			else
			   pos=store[pos].rig;
		}
		else
		{
			if(!store[pos].lef)
			{
				store[pos].lef=++p;
				store[p].val=x;
				break;
			}
			else
			   pos=store[pos].lef;
		}
	}
}
void search(int x)
{
	int pos=1;
	while(1)
	{
		if(x==store[pos].val)
		  return;
        else
        {
        	if(x>store[pos].val)
        	{
	          printf("W");	
              pos=store[pos].lef;
        	}
      	    else
      	    {
    	       printf("E");
    	       pos=store[pos].rig;
      	    }
        }
	}
}
int main()
{
    int t,n,tmp,q;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%d",&n);
    	init(n);
    	scanf("%d",&tmp);
    	store[1].val=tmp;
    	for(int i=2;i<=n;i++)
    	{
	    	scanf("%d",&tmp);
	    	insert(tmp);
    	}
    	scanf("%d",&q);
    	for(int i=1;i<=q;i++)
   	    {
 	    	scanf("%d",&tmp);
 	    	search(tmp);
 	    	printf("\n");
 	    }
    }
    return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值