POJ 2828 Buy Tickets 题意&题解&代码(c++)

博客讲述了POJ 2828题目中关于春节前在中国买火车票的场景,涉及到一个插队问题。给定每个人插队的位置和自身编号,需要找出最终的排队顺序。博主通过线段树数据结构解析了问题,并提供了C++代码实现。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Buy Tickets

Time Limit: 4000MS Memory Limit: 65536K
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

中文题意:人们一个一个的来排队并插队,按人到来的顺序给出每个人插队的位置pos【i】与自身的号码val【i】,pos【i】表示插在第几个人后面(即插在pos【i】+1的位置),输出最终队伍的情况,多组样例。

解:观察发现,最后一个插入到该位置的人位置是固定的,那么我们可以从后面进行插入操作,对于每一个pos【i】 代表val【i】要插入到pos【i】+1位置,那么就是说 i 前面要留出 pos【i】个位置,

线段树 :tree[i].val 记录 该区间 目前还剩 tree[i].val个空位,每一次 add_tree(即插入)的时候 ,如果 该节点 tree[lson].val >=pos[i],那么只要在左儿子找就可以了,否则要在右儿子中找 ,此时左儿子的空位全部空出,所以只要在右儿子中找到空出 pos[i]-tree[lson].val 个位置的位置即可。

附代码如下:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#define lson id*2
#define rson id*2+1
using namespace std;
struct edge{
    int val;   \\表示第i个节点中共有多少空位
}tree[800005];
struct node{
    int x;int y;
}q[200005];    \\记录询问
int n,a[200005];
void push_up(int id)
{
    tree[id].val=tree[lson].val+tree[rson].val;
    return ;
}
void build_tree(int id,int l,int r)
{
    if (l>=r)
    {
        tree[id].val=1;
        return ;
    }
    int mid=(l+r)/2;
    build_tree(lson,l,mid);
    build_tree(rson,mid+1,r);
    push_up(id);
    return ;
}
void add_tree(int id,int l,int r,int x,int v)
{
    if (l==r)
    {
        tree[id].val=0;
        a[l]=v;
        return ;
    }
    int mid=(l+r)/2;
    if (tree[lson].val>=x)
    add_tree(lson,l,mid,x,v);
    else
    {
        x-=tree[lson].val;
        add_tree(rson,mid+1,r,x,v);
    }
    push_up(id);
    return ;
}
int main()
{
    while(cin>>n)
    {
        for (int i=n;i>=1;i--)
        {
            scanf("%d%d",&q[i].x,&q[i].y);
            q[i].x++;
        }
        build_tree(1,1,n);
        for (int i=1;i<=n;i++)
        add_tree(1,1,n,q[i].x,q[i].y);

        for (int i=1;i<n;i++)
        printf("%d ",a[i]);
        printf("%d\n",a[n]);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值