PAT 1013. Battle Over Cities (25)

本文探讨了在战争背景下确保城市间高速公路网连通性的算法挑战。通过输入城市数量、剩余高速公路数量及关注的城市列表,文章提供了一种快速确定若某城市被占领需修复多少条高速公路的方法。该算法采用深度优先搜索策略来计算失去特定城市后,为保持其余城市连通所需的最少新增高速公路数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1013. Battle Over Cities (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

提交代


给你一张图,和一些双向边。问你去点某个点后,需要至少加几条边能使图成为连通图。

只要去掉这个点,然后深搜求下连通分支数,再减一即可。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;
bool pic[maxn][maxn], book[maxn];
int n, m, q;

void dfs(int s)
{
	book[s] = 1;
	for(int i = 1; i <= n; i++)
		if(pic[s][i] && !book[i]) dfs(i);
}

int main(void)
{
	while(cin >> n >> m >> q)
	{
		memset(pic, 0, sizeof(book));
		for(int i = 1; i <= m; i++)
		{
			int x, y;
			scanf("%d%d", &x, &y);
			pic[x][y] = pic[y][x] = 1;
		}
		while(q--) 
		{
			memset(book, 0, sizeof(book));
			int x, ans = 0;
			scanf("%d", &x);
			book[x] = 1;
			for(int i = 1; i <= n; i++)
				if(!book[i]) dfs(i), ans++;
			printf("%d\n", ans-1);
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值