【POJ】-1995-Raising Modulo Numbers(快速幂,同余定理)

本文介绍了一种基于模运算的游戏算法实现,通过快速幂运算和同余原理解决大规模数值计算问题,确保计算效率的同时,降低了内存占用。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Raising Modulo Numbers
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6530 Accepted: 3863

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bifrom all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132
</pre>

Sample Output

2
13195
13

要求就是题目给出的那个式子计算。但是数很大,用快速幂和同余定理做。

许多A^B的和对M求余等于A^B对M求余再求和,和在对M求余。

(A1B1+A2B2+ ... +AHBH)mod M.===((A1^B1)modM+(A2^B2)modM+....(Ah^Bh)modM)modM


#include<cstdio>
#include<algorithm>
using namespace std;
struct node
{
	__int64 p,q,ans;
}a[100010];
int M;								//M定义为全局变量 
__int64 dis(int n,int m)
{
	n=n%M;
	__int64 sum=1;
	while(m)
	{
		if(m&1)
			sum=(sum*n)%M;
		n=(n*n)%M;
		m>>=1;
	}	
	return sum;
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		__int64 ans;
		scanf("%d",&M);
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%I64d %I64d",&a[i].p,&a[i].q);
			a[i].ans=dis(a[i].p,a[i].q);			//分别求出幂对M求余的结果 
		}
		ans=a[1].ans;
		for(int i=2;i<=n;i++)
			ans=(ans+a[i].ans)%M;					//求和在对M求余 
		printf("%I64d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值