【杭电-oj】-1003-Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 211952    Accepted Submission(s): 49797


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

弄清楚ans和sum代表的含义,注意:更新开始临时变量的时间和开始结尾真实变量的时间

#include<cstdio>
int main()
{
	int n;
	int sum,ans,a,b;
	int num[100010];
	int cas=1;
	scanf("%d",&n);
	while(n--)
	{
		sum=0;
		ans=-1001;						//考虑都是负数的情况,最大值即一个最大负数,所以不可以初始化为0 
		int a,b;
		int a1=1;						//临时存放其实位置 
		int m;
		scanf("%d",&m);
		for(int i=1;i<=m;i++)
		{
			scanf("%d",&num[i]);
			sum+=num[i];
			if(sum>ans)
			{
				ans=sum;
				a=a1;				//sum>ans时,起始位置更新 
				b=i;				//主要当sum>ans时,结束点才可以更新 
			}
			if(sum<0)
			{
				sum=0;				//开始新一轮的求和 ,但ans不变 ,直到sum>ans 
				a1=i+1;				//起始位置的临时变量也更新 
			}
		}
		printf("Case %d:\n",cas);
		cas++;
		printf("%d %d %d\n",ans,a,b);
		if(n!=0)
		printf("\n");
	}	
	return 0; 
} 






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值