MIME类型列表

【html 常用MIME类型列表】 本表仅列出了常用的MIME类型,完整列表。浏览器通常使用 MIME 类型(而不是文件扩展名)来确定如何处理 URL,因此 Web 服务器在响应头中添加正确的 MIME 类型非常重要。如果配置不正确,浏览器可能会曲解文件内容,网站将无法正常工作,并且下载的文件也会被错误处理。常用MIME类型列表-使用说明媒体类型(通常称为 Multipurpose Internet Mail Extensions 或 MIME 类型 )是一种标准,用来表示文档、文件或字节流的性质和格式。 阅读详情

MIME 消息能包含文本、图像、音频、视频以及其他应用程序专用的数据。

官方的MIME 信息是由Internet Engineering Task Force (IETF) 在下面的文档中提供的:

             RFC-822 Standard for ARPA Internet text messages

             RFC-2045 MIME Part 1: Format of Internet Message Bodies

             RFC-2046 MIME Part 2: Media Types

             RFC-2047 MIME Part 3: Header Extensions for Non-ASCII Text

             RFC-2048 MIME Part 4: Registration Procedures

             RFC-2049 MIME Part 5: Conformance Criteria and Examples

不同的应用程序支持不同的 MIME 类型。

下面的参考手册是由Microsoft Internet Information Server version 5 所支持的 MIMEI 类型列表。

按照内容类型排列的 Mime 类型列表

类型/子类型

扩展名

application/envoy

evy

application/fractals

fif

application/futuresplash

spl

application/hta

hta

application/internet-property-stream

acx

application/mac-binhex40

hqx

application/msword

doc

application/msword

dot

application/octet-stream

*

application/octet-stream

bin

application/octet-stream

class

application/octet-stream

dms

application/octet-stream

exe

application/octet-stream

lha

application/octet-stream

lzh

application/oda

oda

application/olescript

axs

application/pdf

pdf

application/pics-rules

prf

application/pkcs10

p10

application/pkix-crl

crl

application/postscript

ai

application/postscript

eps

application/postscript

ps

application/rtf

rtf

application/set-payment-initiation

setpay

application/set-registration-initiation

setreg

application/vnd.ms-excel

xla

application/vnd.ms-excel

xlc

application/vnd.ms-excel

xlm

application/vnd.ms-excel

xls

application/vnd.ms-excel

xlt

application/vnd.ms-excel

xlw

application/vnd.ms-outlook

msg

application/vnd.ms-pkicertstore

sst

application/vnd.ms-pkiseccat

cat

application/vnd.ms-pkistl

stl

application/vnd.ms-powerpoint

pot

application/vnd.ms-powerpoint

pps

application/vnd.ms-powerpoint

ppt

application/vnd.ms-project

mpp

application/vnd.ms-works

wcm

application/vnd.ms-works

wdb

application/vnd.ms-works

wks

application/vnd.ms-works

wps

application/winhlp

hlp

application/x-bcpio

bcpio

application/x-cdf

cdf

application/x-compress

z

application/x-compressed

tgz

application/x-cpio

cpio

application/x-csh

csh

application/x-director

dcr

application/x-director

dir

application/x-director

dxr

application/x-dvi

dvi

application/x-gtar

gtar

application/x-gzip

gz

application/x-hdf

hdf

application/x-internet-signup

ins

application/x-internet-signup

isp

application/x-iphone

iii

application/x-javascript

js

application/x-latex

latex

application/x-msaccess

mdb

application/x-mscardfile

crd

application/x-msclip

clp

application/x-msdownload

dll

application/x-msmediaview

m13

application/x-msmediaview

m14

application/x-msmediaview

mvb

application/x-msmetafile

wmf

application/x-msmoney

mny

application/x-mspublisher

pub

application/x-msschedule

scd

application/x-msterminal

trm

application/x-mswrite

wri

application/x-netcdf

cdf

application/x-netcdf

nc

application/x-perfmon

pma

application/x-perfmon

pmc

application/x-perfmon

pml

application/x-perfmon

pmr

application/x-perfmon

pmw

application/x-pkcs12

p12

application/x-pkcs12

pfx

application/x-pkcs7-certificates

p7b

application/x-pkcs7-certificates

spc

application/x-pkcs7-certreqresp

p7r

application/x-pkcs7-mime

p7c

application/x-pkcs7-mime

p7m

application/x-pkcs7-signature

p7s

application/x-sh

sh

application/x-shar

shar

application/x-shockwave-flash

swf

application/x-stuffit

sit

application/x-sv4cpio

sv4cpio

application/x-sv4crc

sv4crc

application/x-tar

tar

application/x-tcl

tcl

application/x-tex

tex

application/x-texinfo

texi

application/x-texinfo

texinfo

application/x-troff

roff

application/x-troff

t

application/x-troff

tr

application/x-troff-man

man

application/x-troff-me

me

application/x-troff-ms

ms

application/x-ustar

ustar

application/x-wais-source

src

application/x-x509-ca-cert

cer

application/x-x509-ca-cert

crt

application/x-x509-ca-cert

der

application/ynd.ms-pkipko

pko

application/zip

zip

audio/basic

au

audio/basic

snd

audio/mid

mid

audio/mid

rmi

audio/mpeg

mp3

audio/x-aiff

aif

audio/x-aiff

aifc

audio/x-aiff

aiff

audio/x-mpegurl

m3u

audio/x-pn-realaudio

ra

audio/x-pn-realaudio

ram

audio/x-wav

wav

image/bmp

bmp

image/cis-cod

cod

image/gif

gif

image/ief

ief

image/jpeg

jpe

image/jpeg

jpeg

image/jpeg

jpg

image/pipeg

jfif

image/svg+xml

svg

image/tiff

tif

image/tiff

tiff

image/x-cmu-raster

ras

image/x-cmx

cmx

image/x-icon

ico

image/x-portable-anymap

pnm

image/x-portable-bitmap

pbm

image/x-portable-graymap

pgm

image/x-portable-pixmap

ppm

image/x-rgb

rgb

image/x-xbitmap

xbm

image/x-xpixmap

xpm

image/x-xwindowdump

xwd

message/rfc822

mht

message/rfc822

mhtml

message/rfc822

nws

text/css

css

text/h323

323

text/html

htm

text/html

html

text/html

stm

text/iuls

uls

text/plain

bas

text/plain

c

text/plain

h

text/plain

txt

text/richtext

rtx

text/scriptlet

sct

text/tab-separated-values

tsv

text/webviewhtml

htt

text/x-component

htc

text/x-setext

etx

text/x-vcard

vcf

video/mpeg

mp2

video/mpeg

mpa

video/mpeg

mpe

video/mpeg

mpeg

video/mpeg

mpg

video/mpeg

mpv2

video/quicktime

mov

video/quicktime

qt

video/x-la-asf

lsf

video/x-la-asf

lsx

video/x-ms-asf

asf

video/x-ms-asf

asr

video/x-ms-asf

asx

video/x-msvideo

avi

video/x-sgi-movie

movie

x-world/x-vrml

flr

x-world/x-vrml

vrml

x-world/x-vrml

wrl

x-world/x-vrml

wrz

x-world/x-vrml

xaf

x-world/x-vrml

xof

按照文件扩展名排列的 Mime 类型列表

扩展名

类型/子类型

 

application/octet-stream

323

text/h323

acx

application/internet-property-stream

ai

application/postscript

aif

audio/x-aiff

aifc

audio/x-aiff

aiff

audio/x-aiff

asf

video/x-ms-asf

asr

video/x-ms-asf

asx

video/x-ms-asf

au

audio/basic

avi

video/x-msvideo

axs

application/olescript

bas

text/plain

bcpio

application/x-bcpio

bin

application/octet-stream

bmp

image/bmp

c

text/plain

cat

application/vnd.ms-pkiseccat

cdf

application/x-cdf

cer

application/x-x509-ca-cert

class

application/octet-stream

clp

application/x-msclip

cmx

image/x-cmx

cod

image/cis-cod

cpio

application/x-cpio

crd

application/x-mscardfile

crl

application/pkix-crl

crt

application/x-x509-ca-cert

csh

application/x-csh

css

text/css

dcr

application/x-director

der

application/x-x509-ca-cert

dir

application/x-director

dll

application/x-msdownload

dms

application/octet-stream

doc

application/msword

dot

application/msword

dvi

application/x-dvi

dxr

application/x-director

eps

application/postscript

etx

text/x-setext

evy

application/envoy

exe

application/octet-stream

fif

application/fractals

flr

x-world/x-vrml

gif

image/gif

gtar

application/x-gtar

gz

application/x-gzip

h

text/plain

hdf

application/x-hdf

hlp

application/winhlp

hqx

application/mac-binhex40

hta

application/hta

htc

text/x-component

htm

text/html

html

text/html

htt

text/webviewhtml

ico

image/x-icon

ief

image/ief

iii

application/x-iphone

ins

application/x-internet-signup

isp

application/x-internet-signup

jfif

image/pipeg

jpe

image/jpeg

jpeg

image/jpeg

jpg

image/jpeg

js

application/x-javascript

latex

application/x-latex

lha

application/octet-stream

lsf

video/x-la-asf

lsx

video/x-la-asf

lzh

application/octet-stream

m13

application/x-msmediaview

m14

application/x-msmediaview

m3u

audio/x-mpegurl

man

application/x-troff-man

mdb

application/x-msaccess

me

application/x-troff-me

mht

message/rfc822

mhtml

message/rfc822

mid

audio/mid

mny

application/x-msmoney

mov

video/quicktime

movie

video/x-sgi-movie

mp2

video/mpeg

mp3

audio/mpeg

mpa

video/mpeg

mpe

video/mpeg

mpeg

video/mpeg

mpg

video/mpeg

mpp

application/vnd.ms-project

mpv2

video/mpeg

ms

application/x-troff-ms

mvb

application/x-msmediaview

nws

message/rfc822

oda

application/oda

p10

application/pkcs10

p12

application/x-pkcs12

p7b

application/x-pkcs7-certificates

p7c

application/x-pkcs7-mime

p7m

application/x-pkcs7-mime

p7r

application/x-pkcs7-certreqresp

p7s

application/x-pkcs7-signature

pbm

image/x-portable-bitmap

pdf

application/pdf

pfx

application/x-pkcs12

pgm

image/x-portable-graymap

pko

application/ynd.ms-pkipko

pma

application/x-perfmon

pmc

application/x-perfmon

pml

application/x-perfmon

pmr

application/x-perfmon

pmw

application/x-perfmon

pnm

image/x-portable-anymap

pot,

application/vnd.ms-powerpoint

ppm

image/x-portable-pixmap

pps

application/vnd.ms-powerpoint

ppt

application/vnd.ms-powerpoint

prf

application/pics-rules

ps

application/postscript

pub

application/x-mspublisher

qt

video/quicktime

ra

audio/x-pn-realaudio

ram

audio/x-pn-realaudio

ras

image/x-cmu-raster

rgb

image/x-rgb

rmi

audio/mid

roff

application/x-troff

rtf

application/rtf

rtx

text/richtext

scd

application/x-msschedule

sct

text/scriptlet

setpay

application/set-payment-initiation

setreg

application/set-registration-initiation

sh

application/x-sh

shar

application/x-shar

sit

application/x-stuffit

snd

audio/basic

spc

application/x-pkcs7-certificates

spl

application/futuresplash

src

application/x-wais-source

sst

application/vnd.ms-pkicertstore

stl

application/vnd.ms-pkistl

stm

text/html

svg

image/svg+xml

sv4cpio

application/x-sv4cpio

sv4crc

application/x-sv4crc

swf

application/x-shockwave-flash

t

application/x-troff

tar

application/x-tar

tcl

application/x-tcl

tex

application/x-tex

texi

application/x-texinfo

texinfo

application/x-texinfo

tgz

application/x-compressed

tif

image/tiff

tiff

image/tiff

tr

application/x-troff

trm

application/x-msterminal

tsv

text/tab-separated-values

txt

text/plain

uls

text/iuls

ustar

application/x-ustar

vcf

text/x-vcard

vrml

x-world/x-vrml

wav

audio/x-wav

wcm

application/vnd.ms-works

wdb

application/vnd.ms-works

wks

application/vnd.ms-works

wmf

application/x-msmetafile

wps

application/vnd.ms-works

wri

application/x-mswrite

wrl

x-world/x-vrml

wrz

x-world/x-vrml

xaf

x-world/x-vrml

xbm

image/x-xbitmap

xla

application/vnd.ms-excel

xlc

application/vnd.ms-excel

xlm

application/vnd.ms-excel

xls

application/vnd.ms-excel

xlt

application/vnd.ms-excel

xlw

application/vnd.ms-excel

xof

x-world/x-vrml

xpm

image/x-xpixmap

xwd

image/x-xwindowdump

z

application/x-compress

zip

application/zip

 

最全的文件扩展名-MIME类型对照表(MIME类型大全).txt 最全的文件扩展名-MIME类型对照表(MIME类型大全) 立即下载

相关推荐

MIME Type 常見的格式類型列表

MIME Type 常見的格式類型列表<br>※ MIME 规范仍在发展中,故尚有变动的可能,此表仅为参考之用。

redis-基础使用

概览 What is Redis? Redis is an open-source, networked, in-memory, key-value data store with optional durability. It is written in ANSI C. The development of Redis is sponsored by Redis Labs today; before that, it was sponsored by Pivotal and VMware. Accordi

邢永胜 - Kyle 1975

【自然语言处理】【聚类】TELL:可解释神经聚类

超越分类的XAI:可解释神经聚类 《XAI Beyond Classification: Interpretable Neural Clustering》 论文地址:https://www.jmlr.org/papers/volume23/19-497/19-497.pdf 一、简介 ​ 本文研究了可解释AI(XAI\text{XAI}XAI)和数据聚类这两个挑战性问题。第一个问题是如何设计一种具有固定可解释性的神经网络,而不是给出一个黑盒模型的事后解释。第二个问题是,使用可微分神经网络来实现离散的k-me

bqw的博客 4140

django报错 AttributeError: ‘SessionStore‘ object has no attribute ‘_session_cache‘

在浏览器上删除cookie后,刷新网页即可

weixin_43361136的博客 2763

安卓光速虚拟机ADB调试实战:从密钥配置到设备连接

本文详细介绍了在安卓光速虚拟机中进行ADB调试的完整实战流程。核心在于通过密钥配置解决设备未授权问题,并启用网络调试与端口映射,最终实现电脑与虚拟机的稳定连接。文章提供了从原理理解、脚本修改到实战命令和疑难排查的全方位指南,帮助开发者和爱好者高效利用光速虚拟机作为移动测试沙盒。

CAT789的专栏 568

DOORS需求管理实战:从汽车设计案例看模块化需求拆分技巧

本文通过一个汽车设计实战案例,深入解析了如何利用DOORS进行模块化需求拆分与管理。从捕获原始用户需求到精炼为可追踪的系统需求,再到按子系统(如自动驾驶)进行模块化拆分,文章详细展示了构建需求骨架、建立可追溯性以及实施变更控制的完整流程,帮助团队在复杂系统工程中实现从混沌到秩序的高效协同。

ww90123的博客 244

java复习第8天---8.3---IO流---Properties

java复习第8天---8.3---IO流---Properties 目录 文章目录1、Properties1.1、概述1.2、存储和遍历1.3、store1.4、load***后记*** : 内容 1、Properties 1.1、概述   java.util.Properties继承于Hashtable,来表示一个持久的属性集。它使用键值对存储数据,每个键对应一个字符串。该类也被许多其他Java类使用,比如获取系统属性时,System.getProperties方法就是返回一个Prpperti

gaogzhen的博客 675

利用ArcGIS快速生成等高线边界,完成地形图拼图

地形图边界一般在CAD中手动绘制,然而,一幅边缘复杂的地形图边界的绘制需要花费大量时间和精力,为了减少重复性工作,提高效率,用ArcGIS软件可以自动生成实测地形图的边界

yl14774636230的博客 9071

修改Android系统 支持的蓝牙传输的文件类型

原文地址:http://blog.csdn.net/hanmengaidudu/article/details/40107937 发送的文件类型,需要修改package/app/bluetooth目录下的AndroidManifest.xml文件的Android:mimeType="" />, 添加相应的类型即可。 接收的文件类型,修改packages/apps/

liu_shd的博客 1356

Matplotlib字体警告终结者:为什么总提示DejaVu Sans?5种场景解决方案大全

本文深入解析Matplotlib中常见的DejaVu Sans字体警告问题,并提供5种典型场景的完整解决方案。从理解字体系统的三层架构和缓存机制,到解决中文显示、远程服务器部署、TeX渲染、缓存优化及生产环境配置等实际问题,帮助开发者彻底摆脱字体警告困扰,实现稳定可靠的数据可视化。

view3的博客 504

DiffusionDriveV2 (1) : 端到端自动驾驶中受强化学习约束的截断扩散建模

DiffusionDriveV2:强化学习约束的截断扩散模型在端到端自动驾驶中的应用 本文针对端到端自动驾驶中扩散模型面临的模式崩溃问题,提出DiffusionDriveV2框架。该方法通过引入强化学习约束,解决了DiffusionDrive依赖模仿学习导致的多样性与持续高质量之间的困境。主要创新包括: 采用尺度自适应乘法噪声促进广泛探索 提出锚点内GRPO管理单个锚点样本间的优势估计 设计锚点间截断GRPO整合全局视角,避免不同驾驶意图间的不当比较 实验表明,该方法在NAVSIM基准测试中达到最先进水平(

@bangbang的博客 382

MIME与IIS 6

一、什么是MIME?二、什么是MIME类型三、解决win2003服务器不能下载iso exe rmvb等文件的问题四、微软的帮助文档:http://www.microsoft.com/china/TechNet/iis/mimeiis.asp一、什么是MIME?用户可以通过使用MIME以设置服务器传送多媒体如声音和动画信息,这一切可能通过CGI脚本来进行。在下面的文章中,你可以...

agnsm00804的专栏 256

宇瞳杯视讯镜头完成版(除公差/鬼像分析)

宇瞳杯视讯镜头完成版(除公差/鬼像分析)

weixin_72050316的博客 1050

MIME类型完整列表

后缀 媒体类型和子类型 .3dm x-world/x-3dmf .3dmf x-world/x-3dmf .a application/octet-stream .aab application/x-authorware-bin .aam application/x-authorware-map .aas application/x-authorware-seg .abc text/vnd.abc .acgi text/h

无意摘花 1337

使用手机录制rosbag包

使用手机作为便携式数据采集设备来录制rosbag。

weixin_38582851的博客 616

ssm框架搭建

这个是一个在idea上成功跑起来的ssm框架项目,保存在这里方便以后使用直接下载

mime 类型列表_MIME类型的完整列表

mime 类型列表 Suffixes applicable Media type and subtype(s) .3dm x-world/x-3dmf .3dmf x-world/x-3dmf .a application/octet-stream .aab application/x-authorware-bin .aam application/x-authorwa...

culi3118的博客 2777

lwip-2.0.3

lwip是瑞典计算机科学院(SICS)的Adam Dunkels 开发的一个小型开源的TCP/IP协议栈。实现的重点是在保持TCP协议主要功能的基础上减少对RAM 的占用。

常见 MIME 类型列表

这是一份 MIME 类型列表,以及各个类型的文档类别,按照它们的常见扩展名排序。 两种主要的 MIME 类型在默认类型中扮演了重要的角色: text/plain表示文本文件的默认值。一个文本文件应当是人类可读的,并且不包含二进制数据。 application/octet-stream表示所有其他情况的默认值。一种未知的文件类型应当使用此类型。浏览器在处理这些文件时会特别小心, 试图防止、避免用户的危险行为. IANA 是MIME 媒体类型的官方注册机构,并维护了list of all the ...

johnhuster的专栏 2567

计算机控制技术及应用

《计算机控制技术及应用》通过总结作者的科研成果和吸收国内外的先进理论、方法和技术,以计算机控制系统的网络化、开放化、智能化和集成化发展趋势为主线索,主要介绍计算机控制系统的基本概念和计算机控制系统的典型形式,计算机控制系统的数学描述与基本分析方法,以及数字PID控制器、最少拍控制系统、达林算法、状态变量设计法等设计方法及其各种改进算法。重点突出计算机控制系统输入输出通道接口的设计方法和典型控制系统的设计案例与实现方法等。

Statistics and Machine Learning Toolbox

Statistics and Machine Learning Toolbox(带书签),MATLAB统计学习工具

Mime 类型列表

按照内容类型排列的 Mime 类型列表 类型/子类型 扩展名 application/envoy evy application/fractals fif application/futuresplash spl application/hta hta application/in

攻城狮Luke 687

iis 中php的mime类型,IIS添加MIME扩展类型及常用的MIME类型列表

经常我在用IIS做为下载服务器的时候有时传上去的文件比如 xxx.iso 文件名名是传上去了,但是用http打开的时候确显示为 404 文件不存在。这其实是IIS对文件的一种保护,不在IIS指定的MIME类型里的文件显不会操作。觉见的有 mp4 / flv / iso / 7z / apk 等扩展名的文件 iis 本身是没c指定MIME类型的,这类文件默认在IIS里是不能下载的。我们可以打开IIS...

weixin_35690047的博客 1114

全部MIME类型列表

所有MIME类型列表官方更新地址 常见的如下: 扩展名文档类型MIME Type .aac AAC audio file audio/aac .abw AbiWorddocument application/x-abiword .arc Archive document (multiple files embedded) ...

aagwpsh7758的博客 656

完整的MIME类型列表

这是一份比较全面的MIME类型列表,关联了文档的类别,以它们常见的扩展名排序。 两种主要的MIME类型在默认类型中扮演了重要的角色: text/plain 表示文本文件的默认值。一个文本文件应当是人类可读的,并且不包含二进制数据。application/octet-stream 表示所有其他情况的默认值。一种未知的文件类型应当使用此类型。浏览器在处理这些文件时会特别小心, 试图避免用户的危险行为....

edmond999的专栏 3719

MIME类型汇总列表

3gp    video/3gppaab   application/x-authoware-binaam   application/x-authoware-mapaas   application/x-authoware-segai       application/postscriptaif     audio/x-aiffaifc   audio/x-aiffaiff    audio/

伏龙的专栏 439
上一篇: Struts1.x NoSuchMethodException的一种可能
下一篇: HTTP状态码
七郎
博客等级 码龄14年 31粉丝 44原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值