POJ 1703 Find them, Catch them 并查集

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.

In the same gang.

题意:t组数据;有m个人,n句话,m个人分为两派 A表示输出两人关系 D表示 表示两人为敌人

代码:

#include<cstdio>
#include<iostream>
#define max 100001
int fa[max];
int dif[max];                              //记录某人的敌人
int n;
int find(int x)
{
	if (x == fa[x])
        return x;
    return fa[x] = find(fa[x]);	                 //更新每个fa[x]   如果直接 return find(fa[x]); 会超时
}

void union1(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
		fa[fx]=fy;
	return;
}
void diff(int x,int y)
{
	if(dif[x]==-1)                //x还没有敌人
		dif[x]=y;	                //y为x的敌人
	else
		union1(dif[x],y);         //x有敌人  将x的老敌人与新敌人组队
	if(dif[y]==-1)
		dif[y]=x;
	else
		union1(dif[y],x);
}
int main()
{
	int t,m,n,c,b;
	int i;
	scanf("%d",&t);
	char a;
	while(t--)
	{
		scanf("%d%d",&m,&n);
		memset(dif,-1,sizeof(dif));
		for( i=1;i<=m;i++)
			fa[i]=i;
		getchar();
		while(n--)
		{
			scanf("%c%d%d",&a,&b,&c);
			getchar();
			if(a=='D')
			{
				diff(b,c);
			}
			else
			{
				if(find(b)==find(c))
					printf("In the same gang.\n");
				else if(find(dif[b])==find(c))
					printf("In different gangs.\n");
				else
				printf("Not sure yet.\n");
			}
		}
	}
	return 0;
}
开始是cin ,cout 写的 也超时了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值